valgrind warning loading layout/reftests/bugs/323656-5.svg

RESOLVED DUPLICATE of bug 386878

Status

()

RESOLVED DUPLICATE of bug 386878
12 years ago
6 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({valgrind})

Trunk
x86
Linux
valgrind
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I see a series of valgrind warnings when loading the reftest mozilla/layout/reftests/bugs/323656-5.svg, starting with:

==20840== Conditional jump or move depends on uninitialised value(s)
==20840==    at 0x7B334CD: nsSVGSVGElement::GetViewboxToViewportTransform(nsIDOMSVGMatrix**) (nsSVGSVGElement.cpp:1265)
==20840==    by 0x7AB5581: nsSVGOuterSVGFrame::GetCanvasTM() (nsSVGOuterSVGFrame.cpp:604)
==20840==    by 0x7AC6FA8: nsSVGForeignObjectFrame::GetCanvasTM() (nsSVGForeignObjectFrame.cpp:465)
==20840==    by 0x7AC7D8C: nsSVGForeignObjectFrame::GetBBoxInternal(float*, float*, float*, float*) (nsSVGForeignObjectFrame.cpp:404)
==20840==    by 0x7AC7E7A: nsSVGForeignObjectFrame::UpdateCoveredRegion() (nsSVGForeignObjectFrame.cpp:331)
==20840==    by 0x7AC79B4: nsSVGForeignObjectFrame::InitialUpdate() (nsSVGForeignObjectFrame.cpp:341)
==20840==    by 0x7AA25C6: nsSVGDisplayContainerFrame::InsertFrames(nsIAtom*, nsIFrame*, nsIFrame*) (nsSVGContainerFrame.cpp:142)

It's possible this is the same as bug 378704, but I really can't tell from reading that bug since there's no information on how to observe the bug.

Updated

12 years ago
Flags: blocking1.9?

Comment 2

11 years ago
Does this still generate valgrind warnings?  Renominate if so.
Flags: blocking1.9?
Keywords: valgrind

Comment 3

10 years ago
WFM on Mac.  dbaron, are you still seeing this?
Assignee: general → nobody
QA Contact: ian → general

Comment 4

6 years ago
Is this still an issue? If so, what ca qa help with here?
Flags: needinfo?(dbaron)
Keywords: qawanted
QA can help with determining whether it's still an issue, i.e., answering comment 2.
Flags: needinfo?(dbaron)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386878
You need to log in before you can comment on or make changes to this bug.