Replace module in nsBookmarkTransactionManager.js with XPCOMUtils.jsm's generateNSGetModule

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Richard Klein, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070516 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070516 Minefield/3.0a5pre

Replace module registration code in nsBookmarkTransactionManager.js with the Components.utils.import("rel:XPCOMUtils.jsm") and generateNSGetModule.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

11 years ago
Blocks: 381189

Comment 1

11 years ago
I don't want to confirm this out of lack of expertise, but I can say this isn't a dupe.

Robin

Updated

11 years ago
Blocks: 381191

Comment 2

11 years ago
I don't see that file (nsBookmarkTransactionManager.js), is this bug still relevant or was the file removed because it's obsoleted by places?
(Reporter)

Comment 3

11 years ago
I believe this file was removed because it's obsoleted by places.  I'm going to mark this as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.