Firefox Closes In Vista If Either 'Computer' Or 'Control Panel' is opened without fail

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Sam Weiss, Unassigned)

Tracking

2.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Running windows vista home premium 32 bit, if firefox is open and i click windows and then either computer or control panel (only I have noticed so far) firefox crashes silently, no errors no beeps, nothing, just closes. Sometimes this goes completely unnoticed until i go looking for my firefox window and sometimes i lead myself to believe i closed it. When I open up Firefox, it says your sessions didn't end properly would you like to resume or being a new session. Very frusterating and very reproducible.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Click Start button
3.Click Control Panel or Computer
Actual Results:  
Silent closing of firefox

Expected Results:  
Stayed in the active window, just like a background app should do
(Reporter)

Comment 1

11 years ago
Im very willing to help with what i can to produce this and im suprised nobody noticed this.
Version: unspecified → 2.0 Branch

Comment 2

11 years ago
I'm unable to reproduce on a new Vista Ultimate install. I'll see if I can setup a Vista home install in an image and try to reproduce. Are there any other details you can give Sam? Have you seen this on any other versions of Vista?
(Reporter)

Comment 3

11 years ago
While this was a problem, I believe I have found the solution, but not exactly a reason. Anyway, while investigating this issue, I noticed that some application hung while this problem occurred. I investigated a little and it seems to have been a stem off of the java engine. As of now, it is documented that the brand new java package with the .xpi extension doesn't work on vista, or some other computers. I uninstalled vistas java engine and all the updates. I took the .xpi file, opened it in notedpad, found the .exe file to which it refrenced, downloaded that, installed it while noting firefox as my primary browser. There have been no issues every since. It seems to have been 2 conflicting version of java. This is a little interesting because this all came preinstalled with vista. Any ideas?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Changing resolution to WORKSFORME since there wasn't a code change that fixed this.
Resolution: FIXED → WORKSFORME

Comment 5

11 years ago
Not at this point, but I'll keep this in my list of things to look at and when I get some free time, I'll take a shot at reporducing. At least we can maybe get some more info posted here in time so folks can find it through search. 
You need to log in before you can comment on or make changes to this bug.