Firefox overrides user changes in extensions.rdf

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I changed a NS1:maxVersion value to 2.0.0.* (while Firefox wasn't running) so that the Reveal extension can be use with Firefox 2.0.0.x. But the next time I opened Firefox, the value was changed back to 2.0.0.1. So, the consequence is that extensions that are no longer supported can no longer be used.

Reproducible: Didn't try
Component: Extension Compatibility → Extension/Theme Manager
QA Contact: extension.compatibility → extension.manager
I was unable to reproduce this, changing maxversion manually in extensions.rdf persisted ok. I'm guessing though that it will get overwritten when the extension is checked for compatibility updates.

That said I don't think manually editing extensions.rdf should ever be supported. There is already a setting in place to allow you to use incompatible add-ons without any such hacking (http://kb.mozillazine.org/Extensions.checkCompatibility).
Severity: major → normal
(Reporter)

Comment 2

11 years ago
extensions.checkCompatibility doesn't solve the problem, because I still want to check the compatibility of the other extensions. A new preference, e.g. extensions.ignoreCompatibility, that would contain a list of extension names, should probably be added.
This is an extremely rare edge use case to over-ride the normal use case and will most likely be wontfix. To accomplish the same result all you have to do it change the version of the extension as well as what you are already changing (e.g. the minVersion and maxVersion) so that it doesn't find the same version to sync the minVersion and maxVersion with.

Comment 4

11 years ago
Nightly Tester Tools work for me:

http://www.oxymoronical.com/web/firefox/nightly
"Extension compatibility

NTT provides useful tools for testers trying to use extensions that claim to be incompatible with the nightly builds.

    * Mark a disabled extension as compatible with the current build
    * Get easy access to the setting to automatically allow all incompatible extensions "
This is expected behavior. resolving -> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.