Excess/incomplete/hidden news account is created from hostname when profile migration, if both hostname & realhostname is set in prefs.js

RESOLVED WONTFIX

Status

Thunderbird
Account Manager
--
major
RESOLVED WONTFIX
11 years ago
8 years ago

People

(Reporter: Matt Seitz, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

27.64 KB, application/x-javascript
Details
16.27 KB, application/x-pcap
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 2.0.0.0 (20070326)

I have a News/NNTP account which is defined to use "news.gmane.org".  Thunderbird reports it cannot connect to the server.

Reproducible: Always

Steps to Reproduce:
1.  Click on news account in left navigation pand
2.  Click on Manage Newsgroup Subscriptions
3.  Click the Refresh button
Actual Results:  
Thunderbird reports "Failed to connect to server news".

Expected Results:  
Newsgroup list should be displayed.

I took a network trace.  It indicates that Thunderbird queries DNS for "news.neopathnetworks.com" instead of "news.gmane.org".  The "neopathnetworks.com" DNS domain is my default DNS search path.

I checked "about:config" and found:

mail.server.server3.hostname news
mail.server.server3.realhostname news.gmane.org

So it appears that when I enter the host name, it is stored in "realhostname".  But when Thunderbird accesses the NNTP server, it uses "hostname".

I believe this news account was imported from my SeaMonkey settings.
(In reply to comment #0)
> mail.server.server3.hostname news
> mail.server.server3.realhostname news.gmane.org

> Actual Results:  
> Thunderbird reports "Failed to connect to server news".

WORKSFORME with Tb 2.0.0.0 on MS Win XP-SP2.
When changed to non-existing news server from UI(e.g. news.mozilla.org-x, which is saved in realhostname), Tb issued "Failed to connect to server news.mozilla.org-x" correctly.

(Q1) What is displayed for "tracert news.gmane.org" at command prompt?
(Q2) "Failed to connect to server news" appeared after you changed "Server Setting" to "news.gmane.org" from "news" and save change(close setting panel)?

(Reporter)

Comment 2

11 years ago
Q1:  I'll check tracert and attach a network trace after I get home this evening.

Q2:  
A.  The server setting in Thunderbird was never "news".  That might have been the original setting in Seamonkey.  

B.  Yes, the message appeared after I changed "Server Setting" and saved changes.  I even tried changing to an entirely different server, and got the same results.
(In reply to comment #2)
> A.  The server setting in Thunderbird was never "news".  That might have been
> the original setting in Seamonkey.
(Q3) What is set in next keys? (Tools/Options/Advanced/General/Config Editor)
     mail.server.server3.newsrc.file-rel / mail.server.server3.newsrc.file
(Q4) Go config editor, and put "hostname" in filter field.
     Is there any other entry which has data of "news"?
     mail.server.serverN.hostname / mail.server.serverN.realhostname 
> That might have been the original setting in Seamonkey.
If you migrated profile, possibly same as or similar to Bug 381483.
Check all news related entries in prefs.js.
(Reporter)

Comment 5

11 years ago
Created attachment 265612 [details]
prefs.js file

Here's my prefs.js file.
(Reporter)

Comment 6

11 years ago
C:\Documents and Settings\Matt>tracert news.gmane.org

Tracing route to sea.gmane.org [80.91.229.5]
over a maximum of 30 hops:

  1     2 ms     2 ms     2 ms  192.168.37.1
  2    10 ms    10 ms     9 ms  adsl-67-117-130-254.dsl.snfc21.pacbell.net [67.1
17.130.254]
  3    10 ms    10 ms    10 ms  dist2-vlan50.snfc21.pbi.net [206.171.134.131]
  4    10 ms    12 ms    10 ms  bb2-10g2-0.snfcca.sbcglobal.net [216.102.176.226
]
  5    11 ms    12 ms    11 ms  ex1-p14-0.eqsjca.sbcglobal.net [151.164.41.10]
  6    23 ms    23 ms    23 ms  ge5-3-0-1000M.ar1.SJC2.gblx.net [64.208.110.25]

  7   222 ms   179 ms   179 ms  64.215.30.226
  8   179 ms   179 ms   178 ms  c10G-ge-1-1-0.cr1.oea19.no.catchbone.net [193.75
.1.73]
  9   184 ms   194 ms   184 ms  c10G-ge-1-0-0.cr1.osls.no.catchbone.net [193.75.
3.37]
 10   182 ms   182 ms   183 ms  ge-0-1-3.br4.osls.no.catchbone.net [193.75.3.70]

 11   185 ms   183 ms   183 ms  kq-gw.netfonds.no [193.75.5.2]
 12   185 ms   183 ms   184 ms  thaleia1.netfonds.no [80.91.224.7]
 13   185 ms   185 ms   185 ms  sea.gmane.org [80.91.229.5]

Trace complete.
(Reporter)

Comment 7

11 years ago
(In reply to comment #3)

> (Q3) What is set in next keys? (Tools/Options/Advanced/General/Config Editor)
>      mail.server.server3.newsrc.file-rel / mail.server.server3.newsrc.file

mail.server.server3.newsrc.file-rel [ProfD]News/news.rc
mail.server.server3.newsrc.file C:\Documents and Settings\Matt\Application Data\Thunderbird\Profiles\0khpunxq.default\News\news.rc

> (Q4) Go config editor, and put "hostname" in filter field.
>      Is there any other entry which has data of "news"?
>      mail.server.serverN.hostname / mail.server.serverN.realhostname 

mail.server.server9.hostname news

(Reporter)

Comment 8

11 years ago
Created attachment 265618 [details]
Network trace
(Reporter)

Comment 9

11 years ago
mail.server.server9.directory C:\Documents and Settings\Matt\Application Data\Thunderbird\Profiles\0khpunxq.default\News\host-news

mail.server.server9.directory-rel [ProfD]News/news-1

Note:  Neither "host-news" nor "news-1" seems to exist:

C:\Documents and Settings\Matt>dir "C:\Documents and Settings\Matt\Application D
ata\Thunderbird\Profiles\0khpunxq.default\News"
 Volume in drive C has no label.
 Volume Serial Number is DC77-B910

 Directory of C:\Documents and Settings\Matt\Application Data\Thunderbird\Profil
es\0khpunxq.default\News

07/30/2006  04:18 PM    <DIR>          .
07/30/2006  04:18 PM    <DIR>          ..
06/18/2006  08:27 PM    <DIR>          host-news
06/18/2006  08:27 PM    <DIR>          host-news.mozilla.org
06/18/2006  08:27 PM    <DIR>          host-news.sf.sbcglobal.net
06/18/2006  08:27 PM    <DIR>          host-secnews.netscape.com
05/16/2007  09:59 PM    <DIR>          news
05/16/2007  09:57 PM    <DIR>          news.mozilla.org
05/04/2007  12:19 PM             1,254 news.mozilla.org.msf
05/30/2006  08:36 PM                33 news.mozilla.org.rc
05/21/2007  08:57 PM             1,355 news.msf
05/16/2007  10:15 PM               204 news.rc
07/31/2006  09:48 PM    <DIR>          news.sf.sbcglobal.net
05/04/2007  12:19 PM             1,282 news.sf.sbcglobal.net.msf
08/01/2006  10:08 PM                29 news.sf.sbcglobal.net.rc
07/31/2006  09:48 PM    <DIR>          secnews.netscape.com
05/04/2007  12:19 PM             1,208 secnews.netscape.com.msf
12/11/2005  11:09 PM                84 secnews.netscape.com.rc
               8 File(s)          5,449 bytes
              10 Dir(s)   2,494,787,584 bytes free

C:\Documents and Settings\Matt>
Looks to be access of following incomplete news account which was probably created by bug 381387.
(prefs.js)
> mail.server.server9.directory = C:\\Doc...\\News\\host-news
> mail.server.server9.directory-rel = [ProfD]News/news-1
> mail.server.server9.hostname      = news
> mail.server.server9.name          = news
(dir listing)
> 06/18/2006  08:27 PM    <DIR>          host-news
> news-1 direcotory doesn't exist

Other accounts are also affected by Bug 381483, but fortunately no problem in news server access when your case. As far I remember, directory/newsrc.file is simply a converted version of directory-rel/newsrc.file-rel. And following mismatch will be resolved if Account Settings/Server Setting panel is opened and saved again by "OK".
(prefs.js)
> mail.server.server8.directory       = C:\\Doc..\\News\\host-news.mozilla.org
> mail.server.server8.directory-rel   = [ProfD]News/news.mozilla.org
> mail.server.server8.hostname        = news.mozilla.org
> mail.server.server8.name            = Mozilla
> mail.server.server8.newsrc.file     = C:\\Doc..\\News\\news.mozilla.org.rc
> mail.server.server8.newsrc.file-rel = [ProfD]News/news.mozilla.org.rc
(dir listing)
> 06/18/2006  08:27 PM    <DIR>          host-news.mozilla.org
> 05/16/2007  09:57 PM    <DIR>          news.mozilla.org
> 05/04/2007  12:19 PM             1,254 news.mozilla.org.msf
> 05/30/2006  08:36 PM                33 news.mozilla.org.rc
> 05/21/2007  08:57 PM             1,355 news.msf
> 05/16/2007  10:15 PM               204 news.rc

What will happen when you execute next steps for all news account?
 (1) Go Account Settings/Server Settings, and delete mail.server.server9.
     (News account named=news by mail.server.server9.name=news)
     If it doesn't appear, delete from prefs.js or delete thru Config Editor.
 (2) Change "Server Name:" field (Add "-X" after current server name)
     and save by pressing OK to force creation of relhostname entry.
 (3) Go Server Settings again, and change "Server Name:" back to original
     (Remove "-X") and force save by pressing OK.
 (4) Check directory-rel, directory, newsrc.file-rel, newsrc.file-rel,
     hostname, realhostname of all news server.
 (5) Access all news server defined in prefs.js
Depends on: 381483
(Reporter)

Comment 11

11 years ago
(In reply to comment #10)
>  (1) Go Account Settings/Server Settings, and delete mail.server.server9.
>      (News account named=news by mail.server.server9.name=news)
>      If it doesn't appear, delete from prefs.js or delete thru Config Editor.

The "server9" entry did not appear in Account Settings.  I could not figure out how to delete entries through Config Editor (I can add them, and edit them, but I couldn't figure out how to delete them).  So I used Notepad to delete the entries from prefs.js.

Just completing this step seemed to resolve the problem.  But I went ahead and did the other steps.

>  (2) Change "Server Name:" field (Add "-X" after current server name)
>      and save by pressing OK to force creation of relhostname entry.
>  (3) Go Server Settings again, and change "Server Name:" back to original
>      (Remove "-X") and force save by pressing OK.
>  (4) Check directory-rel, directory, newsrc.file-rel, newsrc.file-rel,
>      hostname, realhostname of all news server.
>  (5) Access all news server defined in prefs.js

Everything looks fine now.  Shall I mark this a duplicate of Bug 381483?
Phenomenon of hostname & realhostname case(news & news.gmane.org in your case) is not reported by Bug 381483. Please keep this bug open with setting dependency.  
Changing summary to reflect result of problem analysis.
Summary: Wrong host name used to access news NNTP server → Excess/incomplete/hidden news account is created from hostname when profile migration, if both hostname & realhostname is set in prefs.js

Comment 14

10 years ago
as with bug 45777...
->WONTFIX since 4.x migation has been dropped on trunk. 

If one has an overwhelming need to see this fixed on branch, please attach a patch and reopen the bug.  Also, evaluate whether the issue is a bug or an enhancement request and adjust severity accordingly.
filter bugmail for "4.xmidrop" to delete these messages.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.