Non-english search query does not works

VERIFIED INVALID

Status

SeaMonkey
Search
P3
normal
VERIFIED INVALID
18 years ago
10 years ago

People

(Reporter: Mikhail Khlopotov, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000502
BuildID:    2000050215



Reproducible: Always
Steps to Reproduce:
1.Open Search Sidepanel
2.Type anything in, for example, Russian
3.See that netcenter returns some results with wrong
encoding or whatether-- but is is Unusable and actually has no requested
phrase


Actual Results:  Query is being  URL-encoded, sent to server, but it interpretes
it wrong

Comment 1

18 years ago
reporter, please give me an exact search string (tell me what to type) that demonstrates the problem for you.
(Reporter)

Comment 2

18 years ago
Tehe search string I used was "Челябинск" (it should be in KOI-8 here), it's
in Russian, name of a city -- "Chelyabinsk".
The query is being converted into 
http://google.netscape.com/netscape?query=%D0%A7%D0%B5%D0%BB%D1%8F%D0%B1%D0%B8%D
0%BD%D1%81%D0%BA
or
http://search.aol.com/dirsearch.adp?query=%D0%A7%D0%B5%D0%BB%D1%8F%D0%B1%D0%B8%D
0%BD%D1%81%D0%BA

If I type In the input provided on the searcher's page it converts the same word
into
http://google.netscape.com/netscape?query=%C7%D5%DB%EF%D1%D8%DD%E1%DA
and works fine.

I.e. Mozilla's search URL-encodes the query as UTF8 string (which is default 
behaviour for XUL), but all the search engines do work with some native 
encoding.

Comment 3

18 years ago
setting to NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
Internationalization bug
Assignee: matt → ftang

Comment 5

18 years ago
Internet search issue. reassign to nhotta , cc nwang, bobj and jaimejr
Assignee: ftang → nhotta

Comment 6

18 years ago
Adding Linda Baliman to cc: list.  

Linda please investigate this issue with IQA and engineering.  We need to know 
how severe this issue is, and its impact on the UE to determine if it should be 
nominated for nsbeta3.
(Assignee)

Comment 7

18 years ago
For the side bar search, search description files (i.e. sherlock file) are 
needed per charsets. A charset can be specified in the description file (a 
document is available, 
http://www.mozilla.org/projects/intl/internet_search_charset_spec.html).
If no charset is specified in the description file then "ISO-8859-1" is used.

Mark as invalid since the search description files in the current US build works 
for non English such as French and German. If Russian support is needed then a 
new search description file can be added.
I don't know if we have a Russian lang-pack, adding tao for lang-pack issue.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 8

18 years ago
None that I can think of. Jaime R. is the Project Manager who owns langpacks
 bundling issues.


Hi, Jaime:

Comments?




Thanks

Comment 9

18 years ago
No plans @ this time.

Comment 10

18 years ago
marking VERIFIED based on comments
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.