Closed Bug 381453 Opened 13 years ago Closed 13 years ago

when loaded in frames / iframes, pages that redirect show up in history

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3 alpha5

People

(Reporter: moco, Assigned: moco)

References

()

Details

(Keywords: regression, Whiteboard: [Fx-parity])

Attachments

(2 files, 1 obsolete file)

pages loaded in frame show up in history

in firefox 2, if I use http://webtools.mozilla.org/buster/random/random.html, the pages it loads in the frames don't show up in my history sidebar and history menu.

on the trunk, those items are showing up in both places.

this is a regression from firefox 2, but it may also be a regression in places (as places has the concept of hidden pages.)
an example of where I'm seeing this is in the history menu and the history sidebar.

for example, if you visit www.google.com the iframe on that page shows up as "(no title)" in the history sidebar.
showing up in the history menu for sites like google.com seems bad.  adding to the list for a5.
Flags: blocking-firefox3?
Target Milestone: --- → Firefox 3 alpha5
OS: Windows XP → All
Hardware: PC → All
Assignee: nobody → sspitzer
updating summary.

http://webtools.mozilla.org/buster/random/random.html is critical (or something similar).

I've also got a simpler test case that I can attach to this bug.

the problem is in nsNavHistory::AddVisitChain().  when we process redirects, the redirect transition type TRANSITION_REDIRECT_PERMANENT (5) or TRANSITION_REDIRECT_TEMPORARY (6) is getting stored with the visit, and our history queries hide items where the visit_type is not TRANSITION_EMBED (4).

the fix is to nsNavHistory::AddVisitChain(), so that if we have a redirect that is not the top level, we override the transition type.
Status: NEW → ASSIGNED
Summary: pages loaded in frame show up in history → when loaded in frames / iframes, pages that redirect show up in history
Whiteboard: [Fx-parity]
Attached patch patch (obsolete) — Splinter Review
Attachment #266011 - Flags: review?(dietrich)
Attached file test case
the page should show up in history, but not the page we load in the iframe, because http://random.yahoo.com/bin/ryl is a redirect.
Comment on attachment 266011 [details] [diff] [review]
patch

r=me, except please add brackets, as that's the toolkit style (per mano).
Attachment #266011 - Flags: review?(dietrich) → review+
Attachment #266011 - Attachment is obsolete: true
Attachment #266022 - Flags: review+
fixed.

Checking in nsNavHistory.cpp;
/cvsroot/mozilla/toolkit/components/places/src/nsNavHistory.cpp,v  <--  nsNavHis
tory.cpp
new revision: 1.126; previous revision: 1.125
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: blocking-firefox3? → blocking-firefox3+
Verified in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/200707270404 Minefield/3.0a7pre.
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.