Bookmark bar has problems with background color when OS themes applied

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: mafro1, Unassigned)

Tracking

Details

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4pre) Gecko/20070518 Camino/1.6a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4pre) Gecko/20070518 Camino/1.6a1pre

When camino is the active program the bookmark bar does not change background colors or meld with the rest of OSX theming (for when 3rd party themes are applied aka ShapeShifter) I believe this to be a simple error though I can't find it myself. All other parts of Camino and bars work and look perfectly normal. I was thinking this might be a cocoa coloring problem as it just affects the background of the bookmark toolbar.

Reproducible: Always

Steps to Reproduce:
1.install Shapeshifter
2.change theme (dark themes make problem more apparent.)
3.Start Camino (currently tested on Intel) 
Actual Results:  
Notice bookmark bar when camino is in focus should be default color background while text is changed.

Expected Results:  
all backgrounds should change color to match theme instead of remaining default gray
There's the related bug 376742, but this bug seems to be about making the bookmark bar themeable, which it currently isn't. Not sure if we really want to make it so or not.

Thoughts?

Comment 2

12 years ago
If we can get the start and end values from HITheme or the like we probably should; OS themeing utilities aside, it would be nice to not rely on Apple not, say, changing the coloring of Aqua in a future release.
The bookmark bar is pinstriped; how are start and end colors going to help?  That said, I do agree with comment 2.
Summary: camino bookmark tool bar has problems with background coloring (maybe cocoa coloring isnt applied) when Camino is in focus. → Bookmark bar has problems with background color when OS themes applied
(In reply to comment #3)
> The bookmark bar is pinstriped; how are start and end colors going to help? 
> That said, I do agree with comment 2.

Only on 10.3 and earlier OS versions. On 10.4+, it has a Unified appearance (currently generated in code in a way that is not friendly to themeing, as Stuart mentions in comment 2).

I also agree with comment 2, for the record, so I'll confirm this as a fix-where-we're-getting-our-Unified-colors bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 5

12 years ago
(In reply to comment #4)
> 
> I also agree with comment 2, for the record, so I'll confirm this as a
> fix-where-we're-getting-our-Unified-colors bug.
> 

I would also like to mention that this bug only occurs when camino is in focus.. when another window/program is in focus the color displays correctly. So maybe the problem is already fixed in another area... That might make it easier to fix.(In reply to comment #4)

Comment 6

11 years ago
I'm going to WONTFIX this, since based on all the discussion we've had about favicons and the bookmark bar, blindly applying a background we don't control isn't what we want to do.

Matching arbitrary third-party system theme hacks would be something for a third-party input manager.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX

Comment 7

10 years ago
If you're looking for the splashscreen bug, see bug 481494.
You need to log in before you can comment on or make changes to this bug.