Status

--
enhancement
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: cesar, Assigned: cesar)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

it would be nice if people experimenting with xul explorer didn't have to package their files or fiddle with their profile to test it on firefox. This patch adds a menuitem under tools called "Extension Test". You can read more about it in the following link
http://wiki.mozilla.org/XUL_Explorer:UseCases/Extension_Testing

I only tested this in Linux, because that is the only machine I have access to. So do mention if it does not work in Windows/Mac. But I appreciate any (constructive) criticisms, suggestions, and/or feedback to improve what I have.

Reproducible: Always
(Assignee)

Comment 1

11 years ago
Created attachment 265573 [details] [diff] [review]
proposed solution
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

11 years ago
I have received some feedback which I have posted it up on the wiki (http://wiki.mozilla.org/XUL_Explorer:UseCases/Extension_Testing), and worked on it quietly over the past few days. Here is a summary of what was done :

1. Removed that 700 line rdf library :)
2. Replaced crappy dialog boxes with awesome wizard, that helps guide the user
3. Localized some things that I didn't in the previous patch.
4. Refined the code; took out some things that didn't belong in the class.

So if anyone does try it, I like to hear responses to the wizard, since you have to click next-next-next a few times. :) It didn't bother me.

I'm all for changing the wording if its ambiguous. I don't think it is. Also, I need to know the 'default' paths to the firefox executable in mac/windows. I just left them at XXXX and YYYY. I can refine it once I know the actual values.
(Assignee)

Comment 3

11 years ago
Created attachment 267360 [details] [diff] [review]
this is even better!
Attachment #265573 - Attachment is obsolete: true
Assignee: nobody → cdolivei.bugzilla
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.