Annoying assert in XULPopupListenerImpl::FindDocumentForNode

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
19 years ago
10 years ago

People

(Reporter: Pierre Saslawsky, Assigned: Dan M)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Tested on Mac with a fresh pull from last night.
- Load any page, or no page at all
- Mouseover something, or mouseover nothing
==> Sooner or later (usually every 10 or 20 seconds of normal browsing), you get 
the following assert:

User break at 0D185184 dprintf(const char*, ...)+0008C
 ###!!! ASSERTION: Popup attached to an element that isn't in XUL!: 'Error', file 
nsXULPopupL
istener.cpp, line 357
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  08DB167C  
  0998B7C0    PPC  08D9C33C  main+001C4
  0998B730    PPC  08D9A9A8  main1(int, char**, nsISplashScreen*)+00748
  0998B640    PPC  0CF6CA40  nsAppShellService::Run()+00054
  0998B5F0    PPC  0CEE2BF8  nsAppShell::Run()+00040
  0998B5B0    PPC  0CEE34A8  nsMacMessagePump::DoMessagePump()+00044
  0998B560    PPC  0CEE3CDC  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
0018C
  0998B510    PPC  0DB09D3C  Repeater::DoIdlers(const EventRecord&)+0003C
  0998B4C0    PPC  0DB0ADBC  nsTimerPeriodical::IdleAction(const EventRecord&)+
00018
  0998B480    PPC  0DB0B26C  nsTimerPeriodical::FireNextReadyTimer()+00040
  0998B440    PPC  0DB0B058  nsTimerPeriodical::FireAndReprimeTimer(nsTimerImpl*
)+00138
  0998B3E0    PPC  0DB0A640  nsTimerImpl::Fire()+00058
  0998B3A0    PPC  08CCB0FC  XULPopupListenerImpl::sTooltipCallback(nsITimer*, 
void*)+0005C
  0998B1E0    PPC  08CC8FCC  
XULPopupListenerImpl::FindDocumentForNode(nsIDOMNode*, nsIDOMXUL
Document**)+002A8
  0998B130    PPC  0D18572C  nsDebug::Error(const char*, const char*, int)+0002C
  0998B0F0    PPC  0D185284  nsDebug::Assertion(const char*, const char*, const 
char*, int)+0
005C
 Closing log
(Reporter)

Comment 1

19 years ago
CCd saari because it may be related to bug 38153

Comment 2

19 years ago
I think this is a dup of 38153 
(Assignee)

Comment 3

18 years ago
Nothing this annoying could have survived as long as it took me to get around to 
looking at my new bugs. I can't reproduce this. Tooltips are rather broken and, I 
think, disabled until they can come back less broken.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.