"clean up" button remains greyed out after download completes

VERIFIED FIXED

Status

()

VERIFIED FIXED
12 years ago
6 years ago

People

(Reporter: aja+bugzilla, Assigned: sdwilsh)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070521 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070521 Minefield/3.0a5pre

Also found the following message in the error console.

Error: Ci is not defined
Source file: chrome://mozapps/content/downloads/downloads.js
Line: 485

Reproducible: Always

Steps to Reproduce:
1. Download a file
2. Once it's done, notice "clean up" button still greyed out
3.
Actual Results:  
"clean up" button greyed out after download completes

Expected Results:  
"clean up" button should not remain greyed out when download is complete

This was my first download since the download manager change was checked in.
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

12 years ago
Oops...missed another perhaps more relevant message in the error console:


Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]
Source file: chrome://mozapps/content/downloads/downloads.js
Line: 547

Comment 2

12 years ago
i can actually reproduce this.

"clean up" remains disabled because the downloaded item does not had the focus.
Blocks: 380250
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Comment 3

12 years ago
(In reply to comment #1)
> Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)
> [nsIObserverService.removeObserver]
> Source file: chrome://mozapps/content/downloads/downloads.js
> Line: 547

Naw, that's just because of the first one - the observer never got registered.
(Assignee)

Updated

12 years ago
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 4

12 years ago
Posted patch v1.0 (obsolete) — Splinter Review
Basically, we were updating the database a bit too late.  I'll make a test case for this bug tomorrow.
Assignee: nobody → sdwilsh
Status: NEW → ASSIGNED
Attachment #265643 - Flags: review?(gavin.sharp)
(Reporter)

Updated

12 years ago
Blocks: 381546
(Assignee)

Updated

12 years ago
Blocks: 381562
(Assignee)

Updated

12 years ago
Blocks: 381552
(Assignee)

Comment 5

12 years ago
Posted patch v1.1 (obsolete) — Splinter Review
Includes test changes to actually test for this bug.
Attachment #265643 - Attachment is obsolete: true
Attachment #265684 - Flags: review?(gavin.sharp)
Attachment #265643 - Flags: review?(gavin.sharp)
(Assignee)

Comment 6

12 years ago
Comment on attachment 265684 [details] [diff] [review]
v1.1

There are still a few minor issues here, I don't want to have you review this yet.
Attachment #265684 - Flags: review?(gavin.sharp)
(Assignee)

Comment 7

12 years ago
Posted patch v1.2 (obsolete) — Splinter Review
This also includes some stuff from Bug 381646 (just the test file).  I had to refactor things a bit to actually do this right.
Attachment #265684 - Attachment is obsolete: true
Attachment #265735 - Flags: review?(gavin.sharp)

Updated

12 years ago
Blocks: 381601
(Assignee)

Comment 8

12 years ago
Posted patch v1.3Splinter Review
Addresses comments from irc.
Attachment #265735 - Attachment is obsolete: true
Attachment #265735 - Flags: review?(gavin.sharp)
(Assignee)

Comment 9

12 years ago
Checking in toolkit/components/downloads/src/nsDownloadManager.h;
new revision: 1.24; previous revision: 1.23
Checking in toolkit/components/downloads/src/nsDownloadManager.cpp;
new revision: 1.78; previous revision: 1.77
Checking in toolkit/mozapps/downloads/content/downloads.js;
new revision: 1.57; previous revision: 1.56
Checking in toolkit/components/downloads/test/unit/test_download_manager.js;
new revision: 1.8; previous revision: 1.7
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

12 years ago
WFM now.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070523 Minefield/3.0a5pre ID:2007052316 [cairo]
Status: RESOLVED → VERIFIED

Updated

12 years ago
Depends on: 381803
No longer depends on: 381803

Updated

12 years ago
Flags: in-testsuite+
Product: Firefox → Toolkit

Comment 11

6 years ago
Exactly the same behaviour in FF 19.0!!!!

Download DialogBox always shows "clear list" button as greyed out in FF 19.0
(In reply to L.I.A.R. from comment #12)
> Created attachment 718953 [details]
> Screenshot of identical error in FF19 (10 years later)!!!

10 years later, is maybe cause that's another bug?
please go to bug 842871.
You need to log in before you can comment on or make changes to this bug.