randomly freeze for 5-10 seconds using "automatic configuration proxy (URL)"

RESOLVED DUPLICATE of bug 769764

Status

()

RESOLVED DUPLICATE of bug 769764
11 years ago
6 years ago

People

(Reporter: dino.lupo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Using Firefox with Siemens internal development network (automatic configuration proxy (URL) http://isapac.it001.siemens.net/) randomly freeze the system and firefox itself for about 5-10 seconds. MS IExplorer works without any freeze with the same configuration. If I change my network cable, connecting to Corporate network with the same automatic proxy configuration, everything goes well. You can think that is a network problem, but only if I run firefox thi happen. I'm using Outlook and IExplorer without problems. I think that firefox has a network code loop that in case of some network error repeats many times the code and than the freeze occurs. After waiting some seconds everything returns normal. If you want I can make an analisys of the problem with every tools you like. Tell me what to do, I want to help the firefox community. Thanks.


Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
This is likely a duplicate of bug 208287 (or perhaps bug 235853). Can you confirm that your proxy-autoconfig file uses isInNet?
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
(Reporter)

Comment 2

11 years ago
Yes, but only in some cases. 
However I send you an extract of proxy configuration in order to permit to better know the problem:

/*
**    automatic proxy configuration
*/

function FindProxyForURL(url, host) {
 var  proxy_new = "PROXY 141.29.216.121:8080";
 if ( shExpMatch(host, "localhost") ) { return "DIRECT"; }
 if ( shExpMatch(host, "localhost.*") ) { return "DIRECT"; }
 if ( shExpMatch(host, "127.0.0.*") ) { return "DIRECT"; }
 if ( isPlainHostName(host) ) { return "DIRECT"; }

if ( shExpMatch(host, "www.myhost.it")
 || shExpMatch(host, "www.myhost.lt")
 ) 
     { return proxy_new; }

 if ( dnsDomainIs(host,  ".myhost.de") ) { return "DIRECT"; }

if ( isPlainHostName(host) ||
     isInNet(host, "141.29.0.0", "255.255.0.0")     
   ) { return "DIRECT"; }

 return	proxy_new;
}



(Reporter)

Comment 3

11 years ago
--- WORKAROUND ---
I found a workaround for my situation;

1. save the configuration file on local machine, and rename it isapac.txt
2. replace the following line
   isInNet(host, "141.29.0.0", "255.255.0.0") 
   with 
   shExpMatch(host, "141.29.*.*")
3. in firefox automatic proxy configuration, reference the local file (ex. file:///C:/isapac.txt)

I hope anyway you can fix the bug.
Given that replacing the isInNet call fixed the problem, I'm marking this bug as a duplicate of bug 208287.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 208287
(Reporter)

Comment 5

11 years ago
Sorry, my mistake, but after removing isInNet, the problem occurs less frequently, but it is unresolved. 
If I can help you let me know.


Resolution: DUPLICATE → INCOMPLETE
"INCOMPLETE" means that the report itself is not complete, which I don't think is what you're trying to say.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 7

11 years ago
Sorry, my mistake. 
I mean the problem is not disappeared. 

Comment 8

11 years ago
Same bug and discussion: https://bugzilla.mozilla.org/show_bug.cgi?id=309582

Comment 9

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Hello, i confirm this bug. It appears on 2007-08-18 after the automatic upgrade. With automatic proxy, firefox freeze about 5 seconds, every times on my computer, and there is no proxy on my network. I've no problem with previous version.
I check "direct internet connection" to bypass it and save my time.

Hope this can help you.

Comment 10

7 years ago
I have same type of freezes. But I am not using any type of proxy. This might be a unrelated bug. But this sounds like what I have been dealing with. When this happens the CPU usage on Firefox 5.0 jumps to 50% (100% on CPU0 or CPU1) then Firefox hangs for up to 10 to 20 seconds.

This happens when loading web pages, when loading bookmarks. This also happens at random when just using web pages and scrolling trough them. I have tried to make a bug trace on this issue. But I have not had any luck doing so.

Here is how my version of Firefox is compiled. I am running Gentoo Linux.

-----

emerge firefox --info
Portage 2.1.10.3 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38-gentoo-r6 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.38-gentoo-r6-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-2.0.3
Timestamp of tree: Sun, 14 Aug 2011 05:45:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10.1 sun-bcla-java-vm @GPL-COMPATIBLE @OSI-APPROVED @EULA atheros-hal BitstreamVera"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://ftp.rhnet.is/pub/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="is_IS.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="is da"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://192.168.1.1/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aacs aalib ace acl acpi aim alsa amd64 animgif ansi apm apng applet archive asf asn avcodec avformat berkdb bluetooth bluray branding bzip2 cairo cdb cdda cddb cdf cdinstall cdmamodem cdparanoia cdr cdrdao cdrom cdsound checksum chipcard chm cli consolekit cracklib crypt crypto cryptokit css cups cxx dbus dc1394 declarative djvu dk dri dtmf dts dv dvb dvbsetup dvd dvdnav dvdr dvi dxva2 ebook emboss encode exif extras fam ffmpeg firefox flac fortran gd gdbm gdm gdu gif gpg gphoto2 gpm gps gpsd gpu gsm gstreamer gtk gzip h224 h281 h323 iconv icu id3 id3tag ident idn ieee1394 image-cache imagemagick imaging imap imlib ios iplayer ipod ipv6 irc is java java6 javacomm javascript jbig jce jpeg jpeg2k kde kdecards kdrive kipi lame lcms ldap libass libcaca libnotify libv4l libv4l2 live lzma mad maps matroska md5 md5sum md5sum-external midi mjpeg mkl mms mmx mmxext mng modules mozilla mp3 mp3rtp mp3tunes mp4 mpeg mpg123 mplayer mudflap multilib multiprocess musicbrainz mysqli ncurses nfs nls nntp nokia npp nptl nptlonly nsplugin nss nsscache ntfs ntlm ogg ogg123 ogm openal openexr opengl openmp openpgp pam pango pcre pda pdf perl phonon plasma png policykit ppds pppd pulseaudio python qt3support qt4 quicktime quvi raw readline rtmp rtsp samba scanner scp sdl seamonkey secure-delete semantic-desktop session sftp smartcard smp sms smtp snmp sox spamassassin spell sqlite srt srtp sse sse2 sse3 ssl startup-notification svg sysfs system-sqlite szip tcpd theora thumbnail thumbnails tiff truetype udev unicode unlock-notify unzip upnp usb v4l v4l2 vaapi vcd vcdx vdpau vorbis webcam wma wma-fixed wmf x264 xcb xcomposite xinerama xml xorg xosd xscreensaver xulrunner xv xvid youtube zip zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="is da" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

www-client/firefox-5.0-r2 was built with the following:
USE="alsa (consolekit) dbus ipc libnotify methodjit (multilib) (policykit) startup-notification system-sqlite webm -bindist -custom-cflags -custom-optimization -debug -pgo -wifi" LINGUAS="da is -af -ak -ar -ast -be -bg -bn -bn_BD -bn_IN -br -bs -ca -cs -cy -de -el -en -en_GB -en_US -en_ZA -eo -es -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gd -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -hy -hy_AM -id -it -ja -kk -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb -nb_NO -nl -nn -nn_NO -nso -or -pa -pa_IN -pl -pt -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh -zh_CN -zh_TW -zu"                                                                                   
CFLAGS="-march=athlon64 -pipe -mno-avx"
CXXFLAGS="-march=athlon64 -pipe -mno-avx"

----

This bug is really annoying and needs to be found and fixed.
Please test with a recent Gecko trunk. This should be now fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769764
You need to log in before you can comment on or make changes to this bug.