Closed Bug 381555 Opened 13 years ago Closed 11 years ago

"Show only display name" does only work for personal address book

Categories

(Thunderbird :: Mail Window Front End, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3

People

(Reporter: whimboo, Assigned: standard8)

References

()

Details

(Whiteboard: [mozmill or litmus test required])

Attachments

(1 file)

If you have several address books (eg. private, business) the activation of the pref "Show only display name for people in my address book" does only work for the first address book. If you insert someone from the second or further address book the whole email address is displayed.

We should search within all address books until we find the appropriate person.
Depends on: 240138
Summary: "Show only display name" does only work with first address book → "Show only display name" does only work for personal address book
Herik, can you provide steps to reproduce the bug?  Thanks
Steps to reproduce:

1) Enable the option in Thunderbird:  "Tools > Options > Advanced > Show only display name for people in my address book"

2) Open Thunderbird's address book.

3) Use "File > New > Address Book" to create a new address book.

4) Select the new address book and add a new person,
   e.g. Joe Blow with an email address of joeblow@a.com

5) Send an email from Joe to yourself.  You can either create a new Thunderbird identity to do this ("Tools > Account Settings > (YourAccountName) > Manage Identities") or send the email from some other program or webmail that allows you to change the FROM information.

6) Click on the "Get Mail" button.  Click on the email from Joe.  Look at the FROM header in the headers pane.

Actual result:
Thunderbird says "From: Joe Blow <joeblow@a.com>"

Expected result:
Thunderbird says "From: Joe Blow"

The TO/CC/BCC headers in the headers pane should work in the same way as the FROM header.  Thanks!
(In reply to comment #2)
> Steps to reproduce:
> 
> 1) Enable the option in Thunderbird:  "Tools > Options > Advanced > Show only
> display name for people in my address book"
> 
> 2) Open Thunderbird's address book.
> 
> 3) Use "File > New > Address Book" to create a new address book.
> 
> 4) Select the new address book and add a new person,
>    e.g. Joe Blow with an email address of joeblow@a.com
> 
> 5) Send an email from Joe to yourself.  You can either create a new Thunderbird
> identity to do this ("Tools > Account Settings > (YourAccountName) > Manage
> Identities") or send the email from some other program or webmail that allows
> you to change the FROM information.
> 
> 6) Click on the "Get Mail" button.  Click on the email from Joe.  Look at the
> FROM header in the headers pane.
> 
> Actual result:
> Thunderbird says "From: Joe Blow <joeblow@a.com>"
> 
> Expected result:
> Thunderbird says "From: Joe Blow"
> 
> The TO/CC/BCC headers in the headers pane should work in the same way as the
> FROM header.  Thanks!
> 

Thanks a lot. The patch is almost ready. I need to make it also works for CC and  BCC and will post it soon.

I posted a patch in bug 243631 which also fix this bug I think.
Depends on: 309057
Assignee: mscott → bugzilla
Blocks: 450724
Depends on: 449618
Priority: -- → P2
No longer depends on: 309057
Status: NEW → ASSIGNED
Attached patch The fixSplinter Review
Makes this work across all address books that implement the cardForEmailAddress function.
Attachment #334241 - Flags: review?(bienvenu)
Comment on attachment 334241 [details] [diff] [review]
The fix

but the options UI is a bit misleading, since we now look in multiple address books, instead of just using the default personal address book.
Attachment #334241 - Flags: review?(bienvenu) → review+
(In reply to comment #6)
> (From update of attachment 334241 [details] [diff] [review])
> but the options UI is a bit misleading, since we now look in multiple address
> books, instead of just using the default personal address book.
> 
Bug 448692 is currently planning on removing that UI. I'll add it to my list of blockers for bug 450724 and I'll track what happens.
Patch checked in, changeset id 135:b6532caf76a6
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080819030054 Shredder/3.0b1pre ID:20080819030054

I checked against cards within the OS X address book and my personal address book. Both works as expected. Further I changed the email address within the OS X card and the full email is displayed. Looks fine. Thanks Mark.

Same question here. Something for Litmus or better to have as automated tests?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
(In reply to comment #9)
> Same question here. Something for Litmus or better to have as automated tests?

Same answer, we have no capability for automated tests on external interfaces. Additionally we have no UI tests at the moment.

Leave it as testsuite? though as we may want to implement a test when we do have chrome tests. 

This FIXED bug is flagged with in‑testsuite?   It would be great if assignee or someone else can clear the flag if a test is not appropriate.  And if appropriate, create a test and plus the flag to finish off the bug.
Whiteboard: [mozmill or litmus test required]
Added https://litmus.mozilla.org/show_test.cgi?id=9511 in BFT and FFT
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.