Closed Bug 381638 Opened 16 years ago Closed 7 years ago

[Mac] Aqua <select> and <input type="text"> don't vertically align with each other

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(3 files)

Attached image screenshot
On http://www.squarefree.com/start/, the Amazon <select> and <input type="text"> don't vertically align with each other.  The <select> is too low.

Tested with a trunk build from half an hour ago, while native-looking Mac form widgets (bug 175279) were temporarily turned on.
Hmm, maybe the <select> is just too tall.  It looks like it's a few pixels taller than Safari's...
Summary: [Mac] <select> and <input type="text"> don't vertically align with each other → [Mac] Aqua <select> and <input type="text"> don't vertically align with each other
The font size in <select>s is too big by a few px, see e.g. bug 262191; that's probably part (if not all) of this.
Depends on: 262191
This is not improved by the smaller font size for the select. 
Attached file testcase
This is just the part of Jesse's page that goes with the screenshot as a local attachment.
Assignee: joshmoz → mstange
Assignee: mstange → nobody
Hi, 

I have tested this issue on Mac OS X 10.10 with FF Nightly 48.0a1 (2016-04-13) and I have noticed that the <input type= "text"> box is bigger than the <select>, please see the attached file. Jesse can you verify this on your end with latest version?
Flags: needinfo?(jruderman)
Attached image printscreen.png
Alignment is correct in latest Nightly 49.0a1, 20160518030234 at https://bug381638.bmoattachments.org/attachment.cgi?id=274091

ovidiu, please file a separate bug for the text box being too tall.  Chrome still displays this bug, but has the text box sized correctly.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(jruderman)
You need to log in before you can comment on or make changes to this bug.