CSS2 page-break-before and page-break-after not implemented

VERIFIED DUPLICATE of bug 24000

Status

()

Core
Printing: Output
P3
normal
VERIFIED DUPLICATE of bug 24000
18 years ago
15 years ago

People

(Reporter: Chris Skates, Assigned: buster)

Tracking

Trunk
mozilla1.0.1
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m15)
BuildID:    20000441805

The CSS2 styles page-break-before and page-break-after are not implemented in
M15, without them there is no way to insert page breaks for printed output. The
behaviour in IE5 is as expected.

Reproducible: Always
Steps to Reproduce:
Load the following HTML and print:
<HTML>
  <HEAD>
    <STYLE>
      P {page-break-after :always}
    </STYLE>
  </HEAD>
  <BODY>
    <P>
      Page 1
    </P>
    <P>
      Page 2
    </P>
    Page 3
  </BODY>
</HTML>


Actual Results:  Only one page is printed.

Expected Results:  The text "Page 1", "Page 2" and "Page 3" should be printed on
3 different pages.

Comment 1

18 years ago
Created attachment 8285 [details]
attached testcase

Comment 2

18 years ago
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
Are we supporting this...
Assignee: dcone → attinasi

Comment 4

18 years ago
Style supports this, it is part of the nsStylePrint structure which can be 
obtained from the style context. When I load the illustrative testcase and dump 
the style contexts I see the page-break-after value is set. My guess is that the 
value is never being retrieved by the block code (block, or rendering?). The 
only references to the mPageBreakAfter field in the nsStylePrint structure are 
in style itself... In fact, no code ever even ask for the eStyleStruct_Print 
from a StyleContext, so it is supported by style but not used by the rest of 
the system. Back to you, Don.
Assignee: attinasi → dcone

Updated

18 years ago
Target Milestone: --- → M19

Comment 5

18 years ago
This is a layout problem.  When the page is layed out for a printer I am 
assuming the page sequencer should obey this. Chris.. who is doing this?
Assignee: dcone → karnaze

Comment 6

18 years ago
Marking remind, since it may not make it in the 1st release.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → REMIND

Comment 7

17 years ago
*** Bug 68297 has been marked as a duplicate of this bug. ***
From bug 68297:

we should add the @page rule and page-break-inside

Comment 9

17 years ago
Proposing for Mozilla1.0. Adding at least minimal support for page-break-before 
and after would be helpful.
Status: RESOLVED → REOPENED
Keywords: mozilla1.0
Resolution: REMIND → ---

Comment 10

17 years ago
Moving to m1.0.1 and buster's list.
Assignee: karnaze → buster
Status: REOPENED → NEW
Target Milestone: --- → mozilla1.0.1
*** Bug 47019 has been marked as a duplicate of this bug. ***
*** Bug 72666 has been marked as a duplicate of this bug. ***
This is identical to bug 24000

*** This bug has been marked as a duplicate of 24000 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 15

15 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.