javascript lock mozilla

VERIFIED DUPLICATE of bug 36745

Status

()

Core
JavaScript Engine
P3
critical
VERIFIED DUPLICATE of bug 36745
18 years ago
17 years ago

People

(Reporter: gaxzero, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m16) Gecko/20000503
BuildID:    2000050308

login to a free webmail account at netscape.com
on the lect nav bar, click "Get Mail"


Reproducible: Always
Steps to Reproduce:
1.login to a free account at webmail.netscape.com
2.on the lect nav bar, click "Get Mail"
3.mozilla freezes.

Actual Results:  freeze
mouse pointer rshows the pointing finger (as if the whol window was a link)
window doesn't redraw.


Expected Results:  behave like IE or Navigator

JS code:
function GetMail(){    top.window.bodyframe.location.href=
"/tpl/Mail/511TXTHKW/List?FolderID=-4&SortUseCase=True";
if ( top.FirstGetMail == true ){
self.location.href="/tpl/Door/511TXTHKW/Menu?Folders=Y&Prefs=n&Other=N&Prem=N";
top.FirstGetMail = false;
}
}


HTML code in BODY
<a href="javascript:GetMail();"
         onMouseOver="window.status='Read your mail'; return true;"
         onMouseOut="window.status=' '; return true;">
         <font face="Helvetica Narrow, Arial Narrow" size=2>
         <b>Get Mail</b>
                 </font>
                </a>

Comment 1

18 years ago
can be dup of bug 37463

Comment 2

18 years ago
Maybe. But the bug report describes the same thing as bug 36745. 

*** This bug has been marked as a duplicate of 36745 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.