Firefox exits without OS error or TalkBack when clicking on HTML link on Web page




11 years ago
11 years ago


(Reporter: Dave Frye, Unassigned)


({crash, qawanted})

Firefox Tracking Flags

(Not tracked)


(Whiteboard: requires "Download Accelorator Plus Integration", URL)


(1 attachment)



11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 1.0.3705)
Build Identifier: Firefox/

This was discovered while doing a google image search on Jessica Alba. Several pages into the seach results I clicked on a link to this picture and Firefox exited.

If I cut and paste the URL into the Address bar the web page displays fine. However, when the URL is a link on a web page and you click the link, the application exits without OS error or Firefox errors. I have verfied this with the nightly build as well. The issues is not with the URL address itself, rather the interpretation of the URL link within Firefox, i.e. a link on a page that is clicked on.

Reproducible: Always

Steps to Reproduce:
1.Open the sample files with the URL enbedded as a hyperlink
2.Click on the link and the application will exit.
Actual Results:  
Paste the above URL into an HTML page and make the link a hyperlink to the same source. Save the HTML page. Open the page in Firefox. You should see a hyperlink to the URL noted above. Click on the link.

Expected Results:  
Firefox exits without error.

The link should have gone to the web site.

Comment 1

11 years ago
Created attachment 265801 [details]
HTML File with Hyperlink to Site

Sample HTML code for cause of Firefox crash.
This doesn't crash for me, in either a branch opt build or trunk debug build, on Windows.

Dave, can you reproduce the issue? Could you provide a talkback ID, by following the instructions at ?

There's no evidence that this is a security bug, so opening accordingly.
Group: security
Keywords: crash, qawanted

Comment 3

11 years ago
A Talkback ID is not generated. I have verified it is enabled. When I click on the link in the sample file the Firefox appliaction simply vanishes. No process is left running, no errors are trapped. Did you plug the URL into the address line or open the attached file and click on the link? Thanks!
(In reply to comment #3)
> Did you plug the URL into the address line or open the attached file and click
> on the link? Thanks!

I've done both, this time with a Mac opt build. Still no crash. Have you tried to reproduce the crash in safe mode ( ? 


Comment 5

11 years ago
Ah! Came up in Safe Mode and the link worked! Started enabling each of the add-ons and found the Download Accelorator Plus Integration to be the culprite. Hey I really appreciate your time and thoughts on this. I am closing the bug ticket. Thanks again!
Last Resolved: 11 years ago
Resolution: --- → FIXED
Resolving INVALID, since this wasn't a problem with Firefox itself. You might want to let the extension author know about the problem.
Resolution: FIXED → INVALID
Whiteboard: requires "Download Accelorator Plus Integration"
You need to log in before you can comment on or make changes to this bug.