[Places] changing the properties of a bookmarked link breaks adding bookmarks

VERIFIED FIXED

Status

()

VERIFIED FIXED
12 years ago
9 years ago

People

(Reporter: me, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a5pre) Gecko/20070523 Firefox/3.0a5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a5pre) Gecko/20070523 Firefox/3.0a5pre

Steps to reproduce:
1. Create a fresh profile under a places build.
2 Open the bookmark manager
3. Right click on a bookmarked link and select "properties".
4. Change the name and click "save changes"
5. Open www.mozilla.org 
6. Try to bookmark it.

Reproducible: Always

Actual Results:  
Bookmarking is now broken.


Running "firefox -safe-mode" > 'continue in safe mode' fixes the broken profile until the steps above are repeated.
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070522 Minefield/3.0a5pre
I see no errors. I stays broken in the same session.
In most cases it doesn't happen anymore after a restart.
Component: Bookmarks → Places
OS: Linux → All
QA Contact: bookmarks → places
Hardware: PC → All
This is a regression since 2007-05-18 19.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Updated

12 years ago
Flags: blocking-firefox3?
Version: unspecified → Trunk
Flags: blocking-firefox3? → blocking-firefox3+
I am able to reproduce this, excellent steps to reproduce Hussam!

In my debug build, on the console I get:

WARNING: Remote chrome not allowed! Only file:, resource:, and jar: are valid.
: file c:/builds/trunk/mozilla/chrome/src/nsChromeProtocolHandler.cpp, line 565

That is bug #380232, for which dietrich has a fix, pending review.

I'm not 100% sure about Ria's regression window (of 2007-5-18) as Mano made this change on 2007-03-26.  But places-bookmarks turned on 2007-05-18, so that does explain the regression date, if Ria was using the trunk (and not a special trunk-places-bookmark build).

Marking as a duplicate.  Please re-open if you disagree.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380232
Yeah, I only tested normal trunk hourlies.
thanks for confirming, Ria.
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

12 years ago
Resolution: DUPLICATE → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.