Stop button should be able to stop loading all tabs

RESOLVED DUPLICATE of bug 211776

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 211776
11 years ago
11 years ago

People

(Reporter: Magnus Bergmark, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.8.1) Gecko/20061023 SUSE/2.0-30 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.8.1) Gecko/20061023 SUSE/2.0-30 Firefox/2.0

When opening a lot of tabs, the user might want to stop them (for example if the user is opening a lot of tabs with videos in them). Now, the user needs to open each tab, press "Stop", open the next tab, press "Stop", and so on.

Reproducible: Always

Steps to Reproduce:
1. Open 10-20 slow loading tabs
2. Try to stop them
Actual Results:  
You are required to switch to each tab and close them individually

Expected Results:  
You should be required to middle/ctrl/command click on the "Stop" button, or perhaps right click and choose "Stop all tabs". This could also be on the tab bar, but that would not be as obvious, although it would also help.

Could probably be done with an extension very easily (just a iteration through the tabs calling the stop methods), but this should be functionality right out of the box.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 211776
You need to log in before you can comment on or make changes to this bug.