Firefox crashed when trying to call the Play method on a QuickTime movie

RESOLVED INVALID

Status

Plugins Graveyard
QuickTime (Apple)
--
critical
RESOLVED INVALID
11 years ago
2 years ago

People

(Reporter: Thai Then, Unassigned)

Tracking

({crash})

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/419 (KHTML, like Gecko) Safari/419.3
Build Identifier: Firefox 2.0.0.3

Firefox crashed when you try to call the Play method on a QuickTime movie in a web page. You will need QuickTime 7.1.6 because this uses the new NPAPI extensions for scripting. This crash only happens when you call the method on an object obtained from a call to getElementById. It does not crash if you call the method directly on the movie object like so: document.movie.Play().

Reproducible: Always

Steps to Reproduce:
1. Save the web page in the additional section
2. Open the web page in Firefox
3. Click on the stop button
Actual Results:  
Firefox crashed

Expected Results:  
The movie should stop playing.

<html>
  <head>
  <script language="JavaScript">
  
    function play()
	{
	  document.getElementById('movie1').Play();
	}

    function stop()
	{
	  document.getElementById('movie1').Stop();
	}

  </script>
  
  </head>
<body>

<EMBED width="480" height="220"
  src="http://images.apple.com/movies/weinstein/miss_potter/miss_potter_h480.mov"
  TYPE="video/quicktime"
  PLUGINSPAGE="www.apple.com/quicktime/download"
  id="movie1"
  name="movie1"
  enablejavascript="true">
</EMBED>

<input type="button" value="play" onclick="play()">
<input type="button" value="stop" onclick="stop()">

</body>
</html>
(Reporter)

Comment 1

11 years ago
Looks like a problem in the NPAPI implementation in the new QuickTime plug-in. The NPObject returned by the plug-in for the NPPVpluginScriptableNPObject always have a retain count of 1. I think this should be fixed in the QuickTime plug-in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX

Updated

11 years ago
Resolution: WONTFIX → INVALID

Updated

11 years ago
Severity: normal → critical
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core

Updated

8 years ago
Component: Plug-ins → QuickTime (Apple)
Product: Core → Plugins
QA Contact: general → apple-quicktime
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.