caret shifts erratically when pasting several times

VERIFIED FIXED in M17

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: marina, Assigned: Joe Francis)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When you copy/paste several times using Ctrl+V into the mail body that contains 
a signature file it goes past signature file.
Steps to reproduce:
- check attach signature file and compose in html boxes;
-open New Mail Composition;
-type some text into mail body,select it, copy it (Ctrl+C);
-paste it using CTRL+V several times;
//note: pasting ignores the signature file and goes past it
(Reporter)

Comment 1

18 years ago
and it doesn't happen with Plain text mail

Comment 2

18 years ago
Does it override the signature file?
(Reporter)

Comment 3

18 years ago
No, it doesn't it pastes after it.

Comment 4

18 years ago
This seems to be a type of copy/paste failure. 
In general, copy/paste seems to be broken in several
different ways right now.

the type of problem marina describes can be reproduced
if you have a pre-set signature and 

1) copy/paste from a message view window.

After 2-3 pasting operation above the pre-set siganture, the focus is
lost and jumps to below the signature lines.

2) If you copy/paste from within the mail composer window,
   an extra CR LF seem to get inserted so that when you paste
   a phrase, you get that phrase and a new line inserted.

3) If you copy from teh Browser window, you don't have any problem.
   Normal pasting is done.

4) If copy/paste from regular Composer window, then you see the same
   problem as descried in this bug.

From all of this, we seem to be making soe errors in copying
depending on where the copying occurred -- perhaps invisible
characters which nonetheless have an effect when pasting.

Try using a phrase and don't include a linebreak when copying for
all of the above test cases.

CC'ing akkana. She might be working on this already.

Comment 5

18 years ago
I think you can observe the same problem in regular Composer
with existing lines of text.

Just have some lines of text in Composer. Copy/paste some text 
from different windows into the area above the existing lines.
try that several times and see that the focus shifts.

Comment 6

18 years ago
bug in composer per momoi's comments.  Reassign to beppe
Assignee: ducarroz → beppe
QA Contact: lchiang → sujay
Summary: HTML compose: copy/paste skips signature file → Focus shifts pasting several lines

Updated

18 years ago
Component: Composition → Editor
Product: MailNews → Browser

Comment 7

18 years ago
I don't understand this bug -- the problem is that the caret moves after
pasting?  If so, let's change the summary so we don't get confused thinking this
is a focus issue.

I don't see any strange behavior on linux when performing the steps given, but
that may be because alt-v and ctrl-v paste don't work any more -- probably
related to the other autocopy and focus bugs -- and middle-mouse paste pastes to
the current mouse location.  I think I've seen other bugs related to the caret
changing places unexpectedly; Simon, do you remember anything like that?

Comment 8

18 years ago
Yes, the caret or the insertion point seems to jump erratically when pasting the same string 
several times. 
Summary: Focus shifts pasting several lines → caret shifts erratically when pasting several times

Comment 9

18 years ago
Simon, can you take a look at this?
Assignee: beppe → sfraser
Target Milestone: --- → M17

Comment 10

18 years ago
cc joe

Comment 11

18 years ago
Joe sez he fixed this.
Assignee: sfraser → jfrancis
(Assignee)

Comment 12

18 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 13

18 years ago
Tomorrow's build?
(Assignee)

Comment 14

18 years ago
right, tomorrow.  
(Reporter)

Comment 15

18 years ago
verified as such in 2000-05-25-08 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.