If the tree has editable="true", editable attribute of treecol will not be effective

RESOLVED DUPLICATE of bug 118683

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 118683
11 years ago
10 years ago

People

(Reporter: dongdongdeng, Assigned: janv)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11

<tree editable="true">
<treecols>
 <treecol editable="false"/>
<treecols>
...
The treecol should be not editable but it can. At the same time, if horizontal scrollbar appears, the position of textbox that for editing treecell will not be correct.


Reproducible: Always

Steps to Reproduce:
1.set tree with attribute editable="true"
2.set treecol editable="false" or set nothing
3
Actual Results:  
Run, and dblclick the treecell, you will find you can edit all the treecell

Expected Results:  
if treecol has editabled="false", we can not edit it.

the edit textbox' position is not correct if there is a horizontal scrollbar
Assignee: nobody → Jan.Varga
Component: General → XP Toolkit/Widgets: Trees
Product: Firefox → Core
QA Contact: general → xptoolkit.trees
Version: unspecified → 1.8 Branch

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 118683

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.