All users were logged out of Bugzilla on October 13th, 2018

default wrong page setup in prefs.js cause printing failed

RESOLVED DUPLICATE of bug 315687

Status

()

--
major
RESOLVED DUPLICATE of bug 315687
12 years ago
11 years ago

People

(Reporter: panemade, Unassigned)

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4) Gecko/20070522 Minefield/3.0a4
Build Identifier: granparadiso-alpha4-source.tar.bz2 and firefox-3.0a5pre.en.US.linux-i686.tar.bz2

This has been successfully reproduced on RHEL5 as well as Fedora Core 6.
What I found is that default printer page size was set wrong and huge in prefs.js
That caused firefox eating huge memory and slowed down my system. Printer was unable to print anything and print dialog hangs for 10-15 min. Also print preview was showing only 1 page whereas actual number of pages was more than 1.
When its set manually to 8.5 x 11 I got quick print out as well as print preview. 

Reproducible: Always

Steps to Reproduce:
1. If using any previously installed firefox (rpm), quit that firefox application.
2. Install either manually from tarball or use nightly build.
3. start firefox from its installed binary location like ./firefox
4. Open any web page and open print command.
5. You will see all your default printer correct configuration say I have Letter size.
6. Give print command.
7. Check how it behaves.
Actual Results:  
Once clicked on print. Observe that its already eaten CPU utilization to 100% and same will continue upto 10-15 min and then that printing page disappears with no actual print on printer.

On terminal you will see same time
GTK Accessibility Module initialized
"/home/parag/mozilla.ps", 310896, 402336
15544.000000 20116.000000
1243520 1609280
which is wrong page setup.

Whereas my printer setting are clearly showing default page size is Letter(8.5x11) inches

Expected Results:  
GTK Accessibility Module initialized
"/home/parag/mozilla.ps", 12240, 15840
612.000000 792.000000
48960 63360


dunno howcome default printer size got changed in prefs.js. when manually set it 8.5 and 11 then I can print it quickly and able to see print preview without any problem.
(Reporter)

Comment 1

12 years ago
remember I think new firefox 3 is using same profile that i was having as default for firefox 2 on FC6 and firefox 1.5.0.7 on RHEL5 OS. But with old profile and old firefox version I was able to print any page without any problem.

Updated

12 years ago
Component: GFX: Thebes → Printing
QA Contact: thebes → printing
Version: unspecified → Trunk

Comment 2

12 years ago
A couple of things: which process is hanging? Firefox or your X server? Also, can you attach gdb to the hung process and get a stacktrace? http://kb.mozillazine.org/Getting_a_stacktrace_with_gdb
Severity: normal → major
Keywords: hang

Comment 3

12 years ago
This is probably the issue from bug 309988. Due to an unnecessary inches->millimeters conversion, the default paper size stored in prefs.js was 25.4  times too large. This was uncovered by the fix for bug 307404; previously mozilla didn't actually use the invalid size. The calculation that was producing the invalid paper size was fixed in bug 309988, but nothing was done about old prefs.js files that still contain the bad default. The huge CPU hit could be from the new cairo-based printing code trying to work with an 18x23 foot printing surface.

The workaround is to open the printer properties dialog, which will select a paper size overwriting the bad settings, and then print so that the setting becomes the new default.

An actual fix would involve sanity-checking the paper size at some appropriate spot.
(Reporter)

Comment 4

12 years ago
(In reply to comment #2)
> A couple of things: which process is hanging? Firefox or your X server? Also,
> can you attach gdb to the hung process and get a stacktrace?
> http://kb.mozillazine.org/Getting_a_stacktrace_with_gdb
> 

Hi,
  I recompiled granparadiso-alpha4-source.tar.bz2 with following options
mk_add_options MOZ_CO_PROJECT=browser
ac_add_options --enable-application=browser
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-png
ac_add_options --with-pthreads
ac_add_options --disable-tests
ac_add_options --enable-debug
ac_add_options --disable-installer
ac_add_options --enable-xinerama
ac_add_options --disable-xprint
ac_add_options --disable-strip
ac_add_options --enable-pango
ac_add_options --enable-svg
ac_add_options --enable-canvas

and started as
./firefox -g -d gdb
and its starts firefox but now after enabling debugging messages when I try to use print command I am getting error and its stops browser to work and I had to kill it.
  Will add those as attachements.
(Reporter)

Comment 5

12 years ago
Created attachment 266026 [details]
debugging information for printing problem
(Reporter)

Comment 6

12 years ago
Ok attaching again same test of starting firefox from console after I reboot machine.
attaching prining-problem-gdb-trace1.txt and Screenshot-printerror.png now.
Remember after i clicked on Ok, it hung the firefox.
(Reporter)

Comment 7

12 years ago
Created attachment 266027 [details]
repeat test after rebooting machine
(Reporter)

Comment 8

12 years ago
Created attachment 266028 [details]
print dialog stops working when firefox started from gdb
Created attachment 268234 [details]
Gerv's "print.*" prefs

As requested in bug 350102 - my print prefs.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 315687
You need to log in before you can comment on or make changes to this bug.