Drag and drop recurring event in calendar view breaks linkage between original recurring event and new one just created

RESOLVED INVALID

Status

RESOLVED INVALID
12 years ago
11 years ago

People

(Reporter: pjricc, Unassigned)

Tracking

Lightning 0.3.1
x86
Windows XP

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Lightning 0.3.1 build 2007021403

This big seems similar (perhaps caused by the same problem) as Bug 359524, but there are enough differences between it and my observation to make me report it.

Create a recurring calendar event, then drag and drop that event to a new day.  Open this event on its new day and the "recurring" button is grayed out and unable to be used to check the occurrence.   However, move ahead the recurring period (day, year, whatever) to the next occurrence of the event and notice that it still remains on the original day of the occurrence, not the new day.

In my opinion, when dragging a recurring event to a new day, there should be a pop-up asking if the change in day should effect just the one occurrence or the entire set of recurring dates.  Additionally. the recurring button within the event should not be grayed out.

Deleting this one occurrence does not affect the rest of the future events within this recurrence period.

Reproducible: Always

Steps to Reproduce:
1.  Create a new event in the calendar and make that event a recurring event (say once per year, every year)
2.  Back in the calendar view, drag that event to a new day
3.  Open the event and notice that the recurrence button is inaccessible.  
4.  Additionally, notice how that event has been separated from the rest of the recurrences and changing this one event has no effect on the rest of the set.


Expected Results:  
I would expect that dragging and dropping a recurring event would have resulted in a pop-up message asking if the change I am making should affect all events within that recurring period, or just the one event I am changing.  Additionally, I would expect that the recurring button not be grayed out.  

Work-around.  Delete the dragged and dropped event and delete the future events, then create a new event on the day you prefer the recurrence to occur.
(Reporter)

Updated

12 years ago
Version: unspecified → Lightning 0.3.1
Previously drag'n'drop also showed the 'All occurrences' vs. 'This occurrence' dialog. This was changed with Bug 352862 to always work on 'This occurrence' on purpose. [http://lxr.mozilla.org/mozilla1.8/source/calendar/base/content/calendar-views.js#151]

Comment 2

11 years ago
As described in comment #1 the reported behavior is not a defect but the intentional behavior.

Dragging one single occurrence out of a series creates an exception from the rule. 

=> invalid because intentional behavior
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.