Last Comment Bug 381877 - simplify the language on the support navigation pages
: simplify the language on the support navigation pages
Status: RESOLVED DUPLICATE of bug 495917
:
Product: support.mozilla.org
Classification: Other
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: David Tenser [:djst]
:
Mentors:
Depends on: 413592
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 08:40 PDT by chris hofmann
Modified: 2009-06-09 15:40 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description chris hofmann 2007-05-24 08:40:28 PDT
a message to webmaster just now writes:

    It would be nice if there was an option to "ask a Question " on the help
    section of Firefox.

    I have been through the site and find no mention of the problem that I have,
    yet there is no support available to help me.

    If I am wrong please advice. I am looking for technial support.


    Regards

-------------------------------------------------------------------------------------

We should add "simplify the language on the support navigation pages" as a requirement...  Here are some ideas:

    Search for an answer to your question in the support [knowledge base*]  ________________________

    Ask our experts a question if you can't find an answer in the [knowledge base*]  ___________________

we should do some testing to see if "knowledge base" is a commonly understood term to novice users..
Comment 1 David Tenser [:djst] 2008-01-18 08:53:02 PST
chofmann, this bug is a little unspecific. Could you clarify what you mean with it?
Comment 2 chris hofmann 2008-01-18 11:41:18 PST
I think this has been fixed for the most part in the current sumo home page.

In light of the primary function of the start page is to streamline navigation to the specific article that has the help that is needed, one suggestion would be to change:

"Welcome to Firefox's community-supported help center. Search our extensive Knowledge Base of articles, tutorials, and how-to's to get answers and tips."

to remove the welcome sentence (do we really think its needed?  how does it jive with the primary function of the goal of the page?). If we need to talk about the community support aspects of the site and the support project maybe add back an  "about this site" link at the bottom.

then also change the second sentence to emphasize that you could :just ask a question in the search box", and chances are we can direct you to an answer...

Here is a crack at a revision:

"Ask a question or search our extensive Knowledge Base of articles, tutorials, and how-to's to get answers and tips."

Cutting down to this (and maybe make it bold) would also allow the top article and new to firefox sections to move a bit higher on the page...
Comment 3 Majken Connor [:Kensie] 2008-01-18 21:08:14 PST
djst had some mock-ups a little bit ago for a redesign that I believed included moving that text out, and putting a revised version (similar to chofmann's suggeston) in the green box, iirc.

I have some code literate live chat helpers, who get bored when things are slow, that could help out with tweaking stuff like this, if that helps.
Comment 4 David Tenser [:djst] 2008-01-25 06:50:14 PST
Here is a more recent mockup I made: http://djst.org/temp/SUMOmockup.png

For the background story, see http://groups.google.com/group/mozilla.support.planning/browse_thread/thread/c348ebc325e67b4c#2e54ba7a5fec2e90
Comment 5 chris hofmann 2008-01-25 10:59:26 PST
looks good.  couple of suggestions.

swap the thunderbird and top 10 list sections, or something that gets the top 10 list into the eye pattern scan of the page sooner.  See

http://www.poynterextra.org/eyetrack2004/main.htm  for reference on this or other studies that indicate that we want the most important info on the page in the top or left hand side of the page.

second suggestion would be to add css to colapse the three column layout down to two or one column if we could.   this would make the page "mobile friendly".

see roc's blog for an example.   load this page http://weblogs.mozillazine.org/roc/ then stretch and shrink the window; watch the number columns expland to 3 and collapse to 1 based on window size.


Comment 6 David Tenser [:djst] 2008-01-28 02:59:41 PST
(In reply to comment #5)
> swap the thunderbird and top 10 list sections, or something that gets the top
> 10 list into the eye pattern scan of the page sooner.  See

Do you mean placing the top 10 list under the main menu? That would again put it under the fold, and make the whole page look very unbalanced. 

Or did you simply mean swapping the left and right columns completely, ending up with a menu on the right side of the page?
Comment 7 David Tenser [:djst] 2008-10-06 07:08:42 PDT
I'm closing this bug. Please reopen for new, specific stuff.
Comment 8 chris hofmann 2008-10-06 07:59:01 PDT
Here is a format that I think works better toward that eyetrack research mentioned above and starts to remove a lot of the redundancy on the page

basically moving to a two column format and getting rid of the loud and redundant and putting just a bit more text into the search box.

  <h2>Firefox Help &amp; Tutorials</h2>

Then make the list of articles in the left column and one line and single space for easier scanning and reading.  

the suggested plan would be to reorg the page like this then measure to see if we could have impact on the 43% exit rate that we currently are seeing.

-------------------------------------------------------------------------------

[mozilla  ]  [products] [addons] [support] [community] [about] [      search]


  |======================================================      Firefox Support
  |                                                     |     
  |  logo   Search the Firefox Support Knowledge Base   |      Knowledgebase
  |  logo                                               |      Ask a Question
  |  logo   __________________________________________  |      Support Forum
  |  logo  |                                         |> |      Other Options
  |        ___________________________________________  |      Contribute
  |======================================================      login

                      
  Popular Suppport Articles                                    New to Firefox?

  1.  ..........................................               ..............
  2.  ..........................................               ..............
  3.  ..........................................               ..............
  4.  ..........................................               ..............
  5.  ..........................................               ..............
  6.  ..........................................
  7.  ..........................................
  8.  ..........................................               Thunderbird
  9.  ..........................................  
 10.  ..........................................               Looking for 
                                                               Thunderbird?
   [See all the support Articles]
Comment 9 Chris Ilias [:cilias] 2008-10-06 21:08:09 PDT
I really like that layout. We need to keep the current width of the sidebar, to fit "Customizing Firefox with add-ons", which is in the "New to Firefox?" section.
Comment 10 chris hofmann 2008-10-06 21:53:54 PDT
I guess this is what things might look like with a bit more content filled in.

There is still some wrapping of some of the long titles and still trying to stay within ~80 characters.   We could think about expanding the left column a bit or try to make the titles a bit more concise.  The "with Firefox 3" articles seem to be the biggest hits on long titles.

Maybe a top 5-10 list that applies to Firefox 3 or the "latest release" could help categorize these a bit better and reduce the title length.  What will we do with these titles if the problems remain in 3.x, 3.5, or 4.0?  Maybe we should consider some rules about version numbers in the titles...

12345678901234567890123456789012345678901234567890123456789012345678901234567890

[mozilla] [products] [addons] [support] [community] [about] [         search]


  |======================================================    Firefox Support
  |                                                     |     
  |  logo   Search the Firefox Support Knowledge Base   |    Knowledgebase
  |  logo                                               |    Ask a Question
  |  logo   __________________________________________  |    Support Forum
  |  logo  |                                         |> |    Other Options
  |        ___________________________________________  |    Contribute
  |======================================================    login


  Popular Suppport Articles                                   New to Firefox?

 1.  Clearing Location bar history                         * Installing Firefox
 2.  Bookmarks, History, and toolbar buttons not           * Using Firefox
     working in Firefox 3                                  * Customizing with
 3.  Firefox 3 will not start on Mac OS X 10.3.9             Addons
 4.  Firefox is already running but is not responding         
 5.  Toolbars and page content appear too large after 
     upgrading to Firefox 3        
 6.  Cannot use or save passwords after upgrading Firefox
 7.  Is my Firefox problem a result of malware
 8.  Common issues fixed in Firefox 3                        Thunderbird
 9.  ..........................................  
10.  ..........................................            * Looking for 
                                                              Thunderbird?
     [See all the support Articles]
Comment 11 chris hofmann 2008-10-06 22:12:38 PDT
added in some of the other ideas kicking around in other bugs and e-mail..

-remove mozilla site search from top right
-add a "tag cloud" for popular search terms to give people a better idea and examples of what to type in, or direct access to several articles around particular search terms...

12345678901234567890123456789012345678901234567890123456789012345678901234567890

[mozilla] [products] [addons] [support] [community] [about]


  |======================================================    Firefox Support
  |                                                     |     
  |  logo   Search the Firefox Support Knowledge Base   |    Knowledgebase
  |  logo                                               |    Ask a Question
  |  logo   __________________________________________  |    Support Forum
  |  logo  |                                         |> |    Other Options
  |        ___________________________________________  |    Contribute
  |======================================================    login

  Popular Search Tags

      Clear History, Can't Save Passwords, Popups, ...

  Popular Suppport Articles                                   New to Firefox?

 1.  Clearing Location bar history                         * Installing Firefox
 2.  Bookmarks, History, and toolbar buttons not           * Using Firefox
     working in Firefox 3                                  * Customizing with
 3.  Firefox 3 will not start on Mac OS X 10.3.9             Addons
 4.  Firefox is already running but is not responding         
 5.  Toolbars and page content appear too large after 
     upgrading to Firefox 3        
 6.  Cannot use or save passwords after upgrading Firefox
 7.  Is my Firefox problem a result of malware
 8.  Common issues fixed in Firefox 3                        Thunderbird
 9.  ..........................................  
10.  ..........................................            * Looking for 
                                                              Thunderbird?
     [See all the support Articles]
Comment 12 Majken Connor [:Kensie] 2008-10-07 11:10:42 PDT
I think this has come up before, but I've forgotten the answer. Is there a reason we don't have the minimized Mozilla menu at the top like MDC and AMO?
Comment 13 David Tenser [:djst] 2008-10-07 13:03:29 PDT
(In reply to comment #12)
> I think this has come up before, but I've forgotten the answer. Is there a
> reason we don't have the minimized Mozilla menu at the top like MDC and AMO?

The reason is that SUMO is part of mozilla.com, so we want it to look like the rest of mozilla.com.
Comment 14 David Tenser [:djst] 2008-10-07 13:08:28 PDT
(In reply to comment #8)
> the suggested plan would be to reorg the page like this then measure to see if
> we could have impact on the 43% exit rate that we currently are seeing.

I definitely like the plan of testing various designs to figure out which one works best for our visitors. I'm meeting with Ken to see about setting up some A/B testing, where we could possibly try some variations and see how that affects our stats. 

Some of the things, like removing headings, or switching order of elements, or changes of wording could probably be tested without too much work. If we can setup a good testing environment, I can see a lot of other stuff we'd want to verify in our design, like placements of links, feedback, etc.
Comment 15 Majken Connor [:Kensie] 2008-10-07 13:39:47 PDT
(In reply to comment #13)
> (In reply to comment #12)
> > I think this has come up before, but I've forgotten the answer. Is there a
> > reason we don't have the minimized Mozilla menu at the top like MDC and AMO?
> 
> The reason is that SUMO is part of mozilla.com, so we want it to look like the
> rest of mozilla.com.

While we're talking about testing and watching metrics I think we should keep this in mind. The top nav is very prominent and does a good job of what it's designed to do - help people coming to mozilla.com get more information and get to the part of community they're looking for. It's certainly a lot more prominent than our side nav.

Once someone is in a specific section where they're actually trying to perform a certain task, rather than browsing what mozilla has to offer, the current trend is to roll up the corp/org specific nav in favor of focusing on the content. Even the store doesn't use this menu. I think this makes sense in our case as well. Not only is there the space issue on the front page, but also the article pages.  I think the 99% case here is when someone is in SUMO, especially on an article page, they mean to be in SUMO. I don't think we can make the case that enough people will need the top nav to get out of SUMO that it makes sense to leave it, rather than to use a tab like the other projects.

IMO it'd be very cool if the Mozilla tab were some sort of rolldown menu so that people didn't have to go back to mozilla.com to go somewhere else (on all mozilla sites). I just don't think there's a precedent or a good usability reason to leaving the full thing on SUMO.
Comment 16 chris hofmann 2008-10-07 20:35:50 PDT
> The reason is that SUMO is part of mozilla.com, so we want it to look like the
> rest of mozilla.com.

The problem I see is that we have created to much redundancy on the page.

"products" links to downloads for firefox (and thunderbird).  they already have firefox if they are at the suppport site.  

"addons" links to the addon site, but we also have a "customizing firefox with addons"

"support"  is a circular link to the site they are are on.

"community" is redunant with the section on the page that describes
  "Improve the Knowledge Base Did you know that most of the content on 
   support.mozilla.com was written by volunteers?
   Find out how you can help:

the "about" link has a bit of orginal content, but also some repetition.

then at the bottom of the page we are linking to all this stuff again
with expansion of detailed links under

Firefox
Addons
Support
Community 
About...


This page should be about 1) search to articles and  2) prominent listing of articles to help easy navigation to the most frequent problems.  That's much more important than trying to generate return traffic to the other mozilla sites or content.

Right now it seems like half of the most important things about the page are hidden below the fold, and the real estate is repeating, over and over, all these other things that are less important to the main objective of the page.
Comment 17 David Tenser [:djst] 2008-10-08 01:57:21 PDT
I think there is too much focus in this discussion to remove items from the design for the sake of getting as much content as possible above the fold, in a belief that visitors leave the site because they didn't understand that there was actually content below the heading. I personally don't think that's the case, but rather than providing my guesses, we should be testing variations of the design to verify what works best for us. 

We can present arguments for and against the current design choices, but without actual proof I'm not prepared to change the design for the sake of changing it. As I said, there is a reason why the top nav is there; SUMO is a top (nav) item on mozilla.com. The logic about it being redundant could be applied to any other page on mozilla.com. If that's actually true, it's not just SUMO that is losing visitors because of too much redundancy in the design.

Let's focus on getting a test environment up so we can actually prove which design/layout works best for us and made decisions based on quantifiable data rather than educated guesses. :)
Comment 18 chris hofmann 2008-10-08 08:28:01 PDT
yes, some study is needed, but a lot of study has already been done.  While we are getting the infrastructure up for A/B testing we need to figure out how we will evaluate the data and develop stategies for making changes.

That article I mentioned in comment 5 has a lot of good detail that I think applies directly to the current design.  These kind of heat map studies are used extensively across many top sites.

Wide variation in font size distracts from scanning and readying detail
http://www.poynterextra.org/eyetrack2004/fontsize.htm
  ...we have huge disparity in largest and smallest, and wide selection of font sizes

blurbs combined with headlines help in encouraging overall reading of the page
http://www.poynterextra.org/eyetrack2004/blurbs.htm
  ...we have only two things that look like blurbs
     "These articles will help you get started and browsing like a pro" &
     "Did you know that most of the content on support.mozilla.com was 
      written by volunteers?"
   niether relates to navigation to the list of top problems and are located
   strategically to have the affect of "getting people to read all the content
   on the page.

the content in the upper left and high priority "heat map" areas is going to get the most attention on the site.
http://www.poynterextra.org/eyetrack2004/viewing.htm

  with the search box near the upper left we do a fairly good job of serving those that know how to search what they are looking for (24%), but less good job leading people to lists of articles they can scan to find descriptions of problems that sound like the things they see on their system... (article list burried middle and low on the page.)
  43% exit the page
  27% click on article links  

In the lowest heat map areas we see traffic patterns that might be expected -- very low.

2% go to Ask a question
2% go to the Forum
1% go to Other Firefox Support


Chris I., 

Do we have any data that tells us about kicks on the top nav bar?  That would also help us figure how many sumo site users are getting value out of those links.

Can we also get data on the distribution of clicks on the top 10 articles on the home page?   Do we see the top 3 or 4 articles substantially higher than the bottom 5-7 articles or is it more of a long tail and uniform distribution?
Comment 19 David Tenser [:djst] 2008-10-08 12:18:26 PDT
(In reply to comment #18)
> Can we also get data on the distribution of clicks on the top 10 articles on
> the home page?   Do we see the top 3 or 4 articles substantially higher than
> the bottom 5-7 articles or is it more of a long tail and uniform distribution?

Quick response to this part. Here's the current list:

1 Clearing Location bar history
2 Bookmarks, History, and toolbar buttons not working in Firefox 3
3 Firefox 3 will not start on Mac OS X 10.3.9
4 Firefox is already running but is not responding
5 Toolbars and page content appear too large after upgrading to Firefox 3
6 Cannot use or save passwords after upgrading Firefox
7 Is my Firefox problem a result of malware
8 Common issues fixed in Firefox 3 

And here's the list ordered by the number of clicks:

8 Common issues fixed in Firefox 3 (2035)
1 Clearing Location bar history (1552)
2 Bookmarks, History, and toolbar buttons not working in Firefox 3 (1369)
4 Firefox is already running but is not responding (1310)
7 Is my Firefox problem a result of malware (998)
3 Firefox 3 will not start on Mac OS X 10.3.9 (403)
6 Cannot use or save passwords after upgrading Firefox (348)
5 Toolbars and page content appear too large after upgrading to Firefox 3 (297)
Comment 20 Majken Connor [:Kensie] 2008-10-08 12:26:19 PDT
just to be sure, what time period are the clicks from?
Comment 21 David Tenser [:djst] 2008-10-08 12:36:01 PDT
October 1 - today.
Comment 22 chris hofmann 2008-10-08 13:23:30 PDT
its interesting that 24% of people scanning the top 8 list go all the way to the bottom.  Thats a good sign that people that find the list might be scanning or reading the whole thing.

1 Clearing Location bar history (1552)			            1552 0.18
2 Bookmarks, History, and toolbar buttons not working in Fx3 (1369) 1369 0.16
3 Firefox 3 will not start on Mac OS X 10.3.9 (403)		     403 0.04
4 Firefox is already running but is not responding (1310)	    1310 0.15
5 Toolbars and page content appear too large after upgrade to Fx3    297 0.03
6 Cannot use or save passwords after upgrading Firefox (348)	     348 0.04
7 Is my Firefox problem a result of malware (998)		     998 0.12
8 Common issues fixed in Firefox 3 (2035)			    2035 0.24
						                    8312

That "general purpose index" article at the end might be a bit skewed.  If someone hasn't found what they need in the article list so far it might be a tendency to click on that in an attempt to get another chance at finding what your looking for.

It would be interesting to see the distribution of exits and links clicked on once they get to
http://support.mozilla.com/en-US/kb/Common+issues+fixed+in+Firefox+3

It would also be interesting if we replaced the specific "common issuses in fx3"  or added a "see all the support articles" at the end of the list if we would see much difference in the data.  I bet the last general purpose article would continue to get a high volume of traffic.

page clicks off of 
http://support.mozilla.com/en-US/kb/Common+issues+fixed+in+Firefox+3
&
http://support.mozilla.com/tiki-wiki_rankings.php?locale=en-US&limit=500&categId=1

would be really interesting to track.  That data along with search gives us that best chance of populating the top10 list with articles that solve the most problems for the largest pool of users.

Do we know how many users find and click the [Browse all Knowledge Base topics] link at the bottom of the page?
Comment 23 chris hofmann 2008-10-08 13:49:31 PDT
It would also be interesting to see if we could weed out "informational" and "definition" articles that are used to support more problem oriented articles.

A rough crack at doing this shows that about 50% of our top articles describe how to fix specific problems and the other 50% are more instructional.  Some of the instructional articles like the AVG article might use some renaming to the title lines up with the specific problem that article is trying to solve.  For instance 

"Server not found" article ranks #69, but the AVG article (one of the solutions to server not found) ranks #2


                                                         1) Profiles
       (server not found?)                 2) Configuring AVG Internet Security
                                                         3) ActiveX
                                                         4) Installing Firefox
                                                         5) Search suggestions
                                                        6) Basic Troubleshooting
7) Firefox cache file was infected with a virus
8) Images or animations do not show
                                                  9) Backing up your information
10) Unable to download or save files
                                               11) Installing Firefox on Windows
12) Firefox is already running but is not responding
13) Error loading web sites
                                                 14) Installing Firefox on Linux
15) Lost Bookmarks
                                            16) Customizing Firefox with add-ons
                                            17) Using Firefox for Windows Update
                                            18) Configuring Windows Firewall
                                            19) Other Firefox support
20) Unable to install add-ons
21) Importing bookmarks and other data from other browsers
22) Java-related issues
                                            23) Managing profiles
                          24) Using the Windows Media Player plugin with Firefox
                                            25) Accessibility
                                            26) Windows Media Player-Information
27) Firefox crashes
                                            28) Safe Mode
                                            29) Upgrading Firefox
30) Video or audio does not play

31) Firefox cannot load web sites but other programs can
32) Firefox will not start
33) Firefox hangs
                                            34) How to use tabbed browsing
35) Troubleshooting extensions and themes
                                            36) Options window
37) How to use the Download Manager
38) Secure Connection Failed
                               39) Recovering important data from an old profile
40) Opening PDF files within Firefox
                                            41) Cookies
                                         42) Using the Flash plugin with Firefox
43) Uninstalling Firefox
                                            44) Pop-up blocker
45) The protocol is not associated with any program
46) Firefox is stuck in Safe Mode
                                     47) Using the Shockwave plugin with Firefox
                                            48) Changing the language pack
49) High memory usage
                                            50) Installing Firefox on Mac


This kind of analysis might help us to get the most bang for the buck out of the top 8 list.  I bet changing "toolbars appear too large (problem affecting extension installers?)" to "images do not show (problem affecting all users)"  might get a lot more hits within the top 8 list...
Comment 24 chris hofmann 2008-10-08 14:00:08 PDT
formating on that list didn't turn out to good.

problem articles on the left.   informational articles on the right.  some text on the right wrapped around.

There are some matches to our current home page top 8 list, but there are some interesting additions to the most popular article page list.

7) Firefox cache file was infected with a virus
8) Images or animations do not show
10) Unable to download or save files
12) Firefox is already running but is not responding
13) Error loading web sites
15) Lost Bookmarks
20) Unable to install add-ons
22) Java-related issues
27) Firefox crashes
30) Video or audio does not play
31) Firefox cannot load web sites but other programs can
32) Firefox will not start
33) Firefox hangs
Comment 25 Chris Ilias [:cilias] 2008-10-08 22:33:56 PDT
(In reply to comment #18)
> Do we have any data that tells us about kicks on the top nav bar?  That would
> also help us figure how many sumo site users are getting value out of those
> links.

If there's a way to get that data, I don't know it. Omniture considers that exiting the site, so it is grouped into the 43% that exit the page.


(In reply to comment #22)
> It would be interesting to see the distribution of exits and links clicked on
> once they get to
> http://support.mozilla.com/en-US/kb/Common+issues+fixed+in+Firefox+3

In September:
14.6% go to en-US/kb/ (which is linked to in the breadcrumbs, moz.com menu, Firefox Support text, and Knowledge Base text)
14.4% exit the site
13.0% go to Firefox+Support+Home+Page (I don't see any links to that URL on the page, so I'm guess that 13% is using the 'back' button)
08.1% go to Upgrading+to+Firefox+3
06.6% go to Ask+a+question
06.1% search
05.1% go to High+memory+usage
04.2% go to Support+Website+Forums
04.2% go to Unable+to+download+or+save+files
03.9% go to Lost+Bookmarks
02.3% go to Disabling+third+party+cookies
02.1% go to Other+Firefox+support
01.7% go to Firefox+prints+pages+incorrectly
01.7% go to Toolbar+keeps+resetting
01.6% go to Back+and+forward+or+other+toolbar+buttons+are+missing
01.5% go to OCSP+error+when+accessing+secure+sites
01.4% go to Troubleshooting+performance+issues+on+Intel+Macs
01.1% go to Gray+bar+below+the+status+bar
00.8% go to tiki-browse_categories.php (which is the "Knowledge Base" breadcrumb and the "Edited articles ready for review" link in the Contributor Tools menu, that you have to be logged in as a contributor to see)
00.5% go to tiki-my_tiki.php (which is "My Personal Dashboard" in the Contributor Tools menu, that you have to be logged in as a contributor to see)
00.5% go to TypeError+avg_DTFox+prefs+has+no+properties

> http://support.mozilla.com/tiki-wiki_rankings.php?locale=en-US&limit=500&categId=1


22.6% Exit the site
09.0% Search
02.7% go to Basic Troubleshooting
02.0% go to the in-product start page
01.8% go to the Support home page (probably using the back button)
01.7% go to Profiles
01.6% go to /en-US/kb/ 
01.5% go to Lost Bookmarks
01.4% go to Java related issues
01.4% go to Error loading web sites
01.3% go to Installing Firefox
01.1% go to Firefox crashes
01.0% go to Ask a question
00.9% go to Configuring AVG
00.9% go to the forum
00.9% go to Firefox will not start
00.9% go to Firefox is already running but is not responding
00.9% go to Using the Java plugin with Firefox
00.8% go to Firefox cache file was infected with a virus
00.8% go to ActiveX

The rest of it is very spread out, so I just exported it:
PDF <http://ilias.ca/sumo/tiki-wiki_rankings-sep.pdf>
DOC <http://ilias.ca/sumo/tiki-wiki_rankings-sep.doc>

> Do we know how many users find and click the [Browse all Knowledge Base topics]
> link at the bottom of the page?

0.7% in September (3010 instances)
Comment 26 David Tenser [:djst] 2008-10-09 01:49:50 PDT
Chris, could you run the same stats for October so we can compare with the stats I shared previously? E.g. how many click on "Browse all KB articles" vs the last item in the top 10 list (Common issues fixed in Firefox 3)?
Comment 27 David Tenser [:djst] 2008-10-09 01:53:18 PDT
(In reply to comment #22)
> its interesting that 24% of people scanning the top 8 list go all the way to
> the bottom.  Thats a good sign that people that find the list might be scanning
> or reading the whole thing.

I take that as a sign that people indeed scan the whole list, which would mean that the fold here isn't as critical as we think in this case (probably as long as at least part of the list is visible above the fold, so they see the start of it).

> That "general purpose index" article at the end might be a bit skewed.  If
> someone hasn't found what they need in the article list so far it might be a
> tendency to click on that in an attempt to get another chance at finding what
> your looking for.


One fairly simple test we could try without setting up complex A/B testing environments is to just move the "Browse all KB topics" link to the end of the common issues list instead of having it visually separated from the list. Just run that for a day and compare the click ratio to see if more people click it, and if it has any effect on the bounce rate and search rate.
Comment 28 chris hofmann 2008-10-09 07:38:33 PDT
> I take that as a sign that people indeed scan the whole list, which would mean
> that the fold here isn't as critical as we think in this case (probably as long
> as at least part of the list is visible above the fold, so they see the start
> of it).

I agree that a high pct. of people that find the list are scanning the entire list of the 8 articles.  Thats a good sign.  I'm still pretty convinced that there is a high pct of visitors (some part of the 42% that exit the site) that are not "seeing" the list at all because it's outside the common hotspot. 

The other thing that is going to make this hard is that the data from "rankings page" and "common issues fixed in firefox 3 pages"  shows a long tail.   We aren't going to find a set of 8-10 articles that helps even 15%-20% solve their problem directly.  I think you said that along the way somewhere and this data confirms that.

We need to get these users that can't search (because they don't have the technical language skills to describe their problem) and don't see their problem in the top 8 list to a page that can help them. The only page that we have that might help these users now is buried way below the fold at the bottom of the page and only 0.7% of visitors found that in September (3010 instances).

Creating a better directory page, or filtered top article page like suggested in comment 23 and 24 is the way to help these people on the end of the long tail of problems.   Then we need to raise the visibility of that link to higher on the page so it can be seen.  Hooking the link to that page onto the end of the list of 8 top articles appears that it might work.

Thats one suggestion. Is there another strategy for trying to reduce the 42% exit number?

Looking at some of the patterns in this data it appears that some number of users are there to solve a specific problem, and others might just be "browsing around."   The "browsing around" pattern could also be a set of users that are lost and grasping for something to help them but don't understand any of it.

I wonder of there are some tweaks to the site that we might do, or some analysis tools or techniques that we might employ to break down vistors into categories of

-well directed to solving their problem
-lost
-just browsing around

ken, any thoughts?

If we had this data that might also allow us to really focus on improving the site for "lost users"  and not get thrown off by browsing around patterns.
Comment 29 ken kovash 2008-10-09 13:47:16 PDT
As much as I like data, it seems like some direct feedback from users could provide eye opening info.  I recently talked with Tenser about integrating a survey into the sumo site.  As one suggestion, please check out: http://4q.iperceptions.com/default.aspx?c=en-US.  This service was developed by Google's Analytics Evangelist, who gave a brown bag at Mozilla a few months ago.
Comment 30 chris hofmann 2008-10-09 14:54:03 PDT
that's an interesting idea...

another one would be to instead of putting a survey in the face of users to put a couple of links on the home and other pages...


[just browsing around?  See our news letter of recent updates and interesting articles on the site]  -- have that point to a blog that we might get started with interesting tid bits about the support site.

[lost?  give us some feedback about what you were looking for and could not find]
Comment 31 Chris Ilias [:cilias] 2008-10-09 15:37:46 PDT
(In reply to comment #26)
> Chris, could you run the same stats for October so we can compare with the
> stats I shared previously? E.g. how many click on "Browse all KB articles" vs
> the last item in the top 10 list (Common issues fixed in Firefox 3)?

Okay, the date you posted was Oct 8, so these are stats for Oct1-Oct8:

<http://support.mozilla.com/en-US/kb/Common+issues+fixed+in+Firefox+3>
15.9% Exited Site	
13.8% go to en-US/kb/ (which is linked to in the breadcrumbs, moz.com menu, Firefox Support text, and Knowledge Base text)
11.9% go to the Support home page (probably using the back button)
08.5% Upgrading+to+Firefox+3
06.5% search
05.9% Ask+a+question
05.4% High+memory+usage
04.7% Unable+to+download+or+save+files
04.2% go to the forum
03.3% Lost+Bookmarks
02.5% Disabling+third+party+cookies
01.8% Other+Firefox+support
01.7% Back+and+forward+or+other+toolbar+buttons+are+missing
01.6% Toolbar+keeps+resetting
01.6% Firefox+prints+pages+in+a+different+layout
01.5% OCSP+error+when+accessing+secure+sites
01.2% Troubleshooting+performance+issues+on+Intel+Macs
01.1% Gray+bar+below+the+status+bar
01.1% tiki-browse_categories.php (which is the "Knowledge Base"
breadcrumb and the "Edited articles ready for review" link in the Contributor Tools menu, that you have to be logged in as a contributor to see)
00.6% en-US/kb/TypeError+avg_DTFox+prefs+has+no+properties


<http://support.mozilla.com/tiki-wiki_rankings.php?locale=en-US&limit=500&categId=1>
24.0% Exited Site
08.9% search
02.7% Basic+Troubleshooting
02.3% go to the in-product start page
01.9% go to the Support home page (probably using the back button)
01.8% Profiles
01.6% en-US/kb
01.5% Lost+Bookmarks
01.4% Java-related+issues
01.3% Error+loading+web+sites
01.2% Firefox+crashes
01.1% Installing+Firefox
01.0% Using+the+Java+plugin+with+Firefox
00.9% go to the forum
00.9% ActiveX
00.9% Ask+a+question
00.9% Backing+up+your+information
00.9% Firefox+is+already+running+but+is+not+responding
00.9% Firefox+will+not+start
00.9% Configuring+AVG+Internet+Security
00.8% Firefox+cannot+load+web+sites+but+other+programs+can
Comment 32 chris hofmann 2008-10-09 19:00:07 PDT
Not much change showing side by side, but this is the kind of report that helps to find "new climbers"

Sept	Oct			
	</en-U/kb/Common+issues+fixed+in+Firefox+3>			
14.4	15.9		 Exited Site    	
13	13.8		 go to en-US/kb/ linked to breadcrumbs, moz.com menu,	
13	11.9		 go to the Support home page (probably the back button)	
8.1	8.5		 Upgrading+to+Firefox+3	
6.1	6.5		 search	
6.6	5.9		 Ask+a+question	
5.1	5.4		 High+memory+usage	
4.2	4.7		 Unable+to+download+or+save+files	
4.2	4.2		 go to the forum	
3.9	3.3		 Lost+Bookmarks	
2.3	2.5		 Disabling+third+party+cookies	
2.1	1.8		 Other+Firefox+support	
1.6	1.7		 Back+and+forward+or+other+toolbar+buttons+are+missing	
1.7	1.6		 Toolbar+keeps+resetting	
1.7	1.6		 Firefox+prints+pages+in+a+different+layout	
1.5	1.5		 OCSP+error+when+accessing+secure+sites	
1.4	1.2		 Troubleshooting+performance+issues+on+Intel+Macs	
1.1	1.1		 Gray+bar+below+the+status+bar	
0.8	1.1		 tiki-browse_categories.php (which is the "Knowledge Base"	
				
				
	0.6		 en-US/kb/TypeError+avg_DTFox+prefs+has+no+properties	
				
				
				
	<http://support.mozilla.com/tiki-wiki_rankings.php?locale=en-US&limit=500&categId=1>			
22.6	24		 Exited Site	
9	8.9		 search	
2.7	2.7		 Basic+Troubleshooting	
2	2.3		 go to the in-product start page	
2	1.9		 go to the Support home page (probably using the back bu
1.7	1.8		 Profiles	
1.6	1.6		 en-US/kb	
1.5	1.5		 Lost+Bookmarks	
1.4	1.4		 Java-related+issues	
1.4	1.3		 Error+loading+web+sites	
1.1	1.2		 Firefox+crashes	
1.3	1.1		 Installing+Firefox	
0.9	1		 Using+the+Java+plugin+with+Firefox	
0.9	0.9		 go to the forum	
0.8	0.9		 ActiveX	
1	0.9		 Ask+a+question	
0.9	0.9		 Backing+up+your+information	
0.9	0.9		 Firefox+is+already+running+but+is+not+responding	
0.9	0.9		 Firefox+will+not+start	
0.9	0.9		 Configuring+AVG+Internet+Security	
	0.8		 Firefox+cannot+load+web+sites+but+other+programs+can
Comment 33 David Tenser [:djst] 2009-06-09 08:39:18 PDT
We're mass-triaging SUMO bugs; I'm going to dupe this to bug 495917 which is a brand new start page implementing most of the ideas proposed in here.

*** This bug has been marked as a duplicate of bug 495917 ***
Comment 34 chris hofmann 2009-06-09 15:40:24 PDT
isn't bug 4959176 the in-product help start page, and this one is about the landing page?

is the plan for both of those pages to look the same?

I still think there are some ideas in here that we need to look at about font size uniformity, compression of the page layout, etc, but agree that all those things might be too messey to track in this bug now.

maybe we need individual bugs to evaluate each one of those ideas in individual bugs and make this, or 495917 meta bugs?

Note You need to log in before you can comment on or make changes to this bug.