history side bar not sorted properly the first time you open it

VERIFIED FIXED in Firefox 3 alpha5

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
Firefox 3 alpha5
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

history side bar not sorted properly the first time you open it.

this is a regression from my checkin for bug #381624
When I make a new profile with a places.sqlite and a bookmarks.html and start it up with a build from before bug 381624 it also gives a wrong view; it is called "By Date" but it shows "By Date and Site". But it only happens one time.
So it is not entirely caused by bug 381624.
ria, the other issue you raise is caused by that checkin.  (I'm able to reproduce it, and when i back out my check in, it is fixed).  thanks for pointing it out.
Status: NEW → ASSIGNED
patch in bug #381624 fixes both the original issue here and ria's issue.
both the original issue here and ria's issue are fixed by the recent check in for bug #381624 
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 5

11 years ago
verified with Windows nightly trunk build from 20070619
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.