view message source fixed font width miscalculations - select highlights wrong text and wrap falls off edge

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: denis.laplante, Assigned: Scott MacGregor)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.0 (20070326)

1- "view message source" is displayed in fixed font, but when selecting 
a block of text the highlight is narrower, as though the 
character width calculations were based on a variable width font.

2- Similarly if Preferences are set to view plain text messages in fixed width,
highlight of selection is off, and wrapped text disappears off right edge of window.

Setting preferences for plain text font to variable width font is a workaround for the second problem but not the first.

This was not a problem in 1.5

Reproducible: Always

Steps to Reproduce:
view message source
select a few lines of text
Actual Results:  
highlight does not cover selected text

Expected Results:  
highlight should cover selected text

This font width problem is absent on my Windows XP machine with the same version number of Thunderbird.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0

Comment 1

11 years ago
Don't see it on linux either, so I'm thinking this is mac only.
Summary: fixed font width miscalculations - select highlights wrong text and wrap falls off edge → view message source fixed font width miscalculations - select highlights wrong text and wrap falls off edge

Comment 2

11 years ago
I am not able to reproduce this in Thunderbird 2.0.0.9 (20071031) on Mac OS X 10.4.11.
Marking WFM based on comment #1 and comment #2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.