Ja IMAP folder names show as utf7 strings on the folder distination menu

VERIFIED WORKSFORME

Status

MailNews Core
Internationalization
P3
major
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: ji, Assigned: Navin Gupta)

Tracking

({intl})

Trunk
Future
All
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
Build: 2000050412 win32 and linux

With new created profile, the Japanese IMAP folder name shows as utf7 strings
on the "Move/Copy Message" folder destination menu. After restart of the
application, the folder name displays alright on the second time.
It might be a dup of bug 30965. But since the problem shows in the different 
place, I filed as a seperate one. Please mark it as a dup if it is.

Steps of reproduce.
1. Have some Japanese folder in your IMAP account.
2. Create a new profile and start Netscape 6 with it.
3. Select Tasks | Mail and connect the messengerto your IMAP account.
4. Highlight one mail in INBOX and select Message | Move Message or Copy Message
   you'll see the Japanese IMAP folder is displayed as utf7 strings on the
   folder destination menu.

Comment 1

18 years ago
Reassign to jefft@netscape.com.
Assignee: nhotta → jefft

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 2

18 years ago
*** Bug 39288 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
Moving to M18 and nominating for beta3.
Keywords: nsbeta3
Target Milestone: M17 → M18

Comment 4

18 years ago
I do not see this using M18 win32 build ID2000073108.
IQA, please test.

Comment 5

18 years ago
- per mail triage.  If we find this to be a necessary fix after int'l mail 
triage, we can revisit.
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future

Comment 6

18 years ago
I can't reproduce this problem on a win98 2000-08-02-05 build w/ the 07-29-04 JA
lang pack installed.
(Reporter)

Comment 7

18 years ago
After the folder is renamed, it shows as a utf7 string until mail is restarted. 
This is probably caused by the same bug that Kat has filed.

Comment 8

18 years ago
>This is probably caused by the same bug that Kat has filed.
Do you know a bug number?
(Reporter)

Comment 9

18 years ago
Bug 30965
I have a fix code.  please wait since I can access CVS sever...

Comment 11

18 years ago
reassigning jefft's bugs to naving
Assignee: jefft → naving
Status: ASSIGNED → NEW

Updated

18 years ago
Severity: normal → minor

Comment 12

18 years ago
mouse slip, was intended to upgrade to major (for i18n tracking purpose)
Severity: minor → major

Updated

18 years ago
Keywords: intl

Comment 13

18 years ago
m_kato, do you have a fix ready?

Updated

18 years ago
Keywords: nsbeta1

Comment 14

18 years ago
marking nsbeta1- per I18N triage.  If there's a fix however, we should get it in.
Keywords: nsbeta1 → nsbeta1-

Comment 15

18 years ago
Mass change of QA contact to ji for the bugs filed by her.
QA Contact: momoi → ji
Momoi san, now I have no environment for access IMAP server since I stay in 
Hottel now :-)
So I will be not able to fix until I am back to my home (feb 2000)...

Comment 17

17 years ago
NHotta - Should this be reassign to Kato-san?

What's the user impact?

Comment 18

17 years ago
Does this still happen? If so, please attach a screen shot of the problem.
(Reporter)

Comment 19

17 years ago
It doesn't happen with a new profile anymore.
But once the folder is renamed, it appears in utf7 string on the menu. 
And this problem is already addressed in bug 70517.
Resolved this bug as wfm.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 20

17 years ago
Marked it as verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.