copy and pasting livemark container in the bookmarks manager results in a feed and a folder with all the items

VERIFIED FIXED in Firefox 3 alpha7

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Christine Yen)

Tracking

Trunk
Firefox 3 alpha7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

copy and pasting livemark container in the bookmarks manager results in a feed and a folder with all the items

steps to reproduce:

1)  create a new profile
2)  open the bm manager dialog
3)  in the left pane, select the bookmarks toolbar folder
4)  in the right pane, select the "Latest Headlines" container
5)  copy, then paste

you'll end up with:

1) a link to the latest headlines rss feed (http://en-us.fxfeeds.mozilla.com/en-US/firefox/headlines.xml)
2) a folder named "Latest Headlines" with all the children of the feed
Created attachment 266153 [details]
screen shot

note, if I were to exit and restart the browser, and view the bm organizer, the feed link would have
please ignore this comment:  "note, if I were to exit and restart the browser, and view the bm organizer, the feed link would have"
Duplicate of this bug: 386258
(Assignee)

Updated

10 years ago
Depends on: 378558
fixed by the fix for bug #378558
Assignee: nobody → cyen
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Firefox 3 M7
note however bug #387138
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 6

10 years ago
Verified with: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071705 Minefield/3.0a7pre

(In reply to comment #5)
> note however bug #387138
> 

yep, seeing that wrong icon behavior, but copy and paste is working correctly otherwise

Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.