[l10n] Corrections to localized Chrome strings in Camino DMG

RESOLVED FIXED

Status

Camino Graveyard
Translations
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Marcello Testi, Assigned: Mark Mentovai)

Tracking

({fixed1.8.1.8})

unspecified
PowerPC
Mac OS X
fixed1.8.1.8
Bug Flags:
camino1.5.1 +

Details

(Whiteboard: [camino-1.5.1])

Attachments

(2 attachments)

25.64 KB, patch
Smokey Ardisson (offline for a while; not following bugs - do not email)
: review+
Details | Diff | Splinter Review
75.59 KB, application/octet-stream
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; it; rv:1.8.1.4) Gecko/20070509 Camino/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; it; rv:1.8.1.4) Gecko/20070509 Camino/1.5

The text before the EULA and the instructions on the upper left need a little tweaking for the languages now available: French, German, Italian, Spanish, Japanese, Korean, Simplified and Traditional Chiness

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Ref. Bug 363010.

Here's the text for French, German, Italian.
(1) = instructions about which button to press
(2) = introduction to EULA

##GERMAN
(1)
Klicken Sie “Akzeptieren”, wenn Sie mit den Bestimmungen des Software-Lizenzvertrags einverstanden sind.
Falls nicht, klicken Sie bitte “Ablehnen” an. Die Software kann nur installiert werden, wenn Sie den Software-Lizenzvertrag akzeptieren.
(2)
Dies ist eine inoffizielle Übersetzung der CAMINO EULA ins Deutsche. Die Vertragsbedingungen für diese Kopie von CAMINO sind darin nicht gesetzlich festgelegt, für eine gültige Interpretation ist ausschließlich die nachstehend angeführte englische EULA-Originalversion heranzuziehen. Wir hoffen jedoch, dass diese Übersetzung zu einem besseren Verständnis der CAMINO EULA für alle deutschsprachigen Nutzer beitragen wird.

##FRENCH
(1)
Vous êtes sur le point d'installer Camino. Veuillez lire le contrat de licence ci-contre. Si vous acceptez les termes de la présente licence, cliquez sur “Accepter” afin d'installer le logiciel. si vous n'êtes pas d'accord avec les termes de la licence, cliquez sur “Refuser”.
(2)
Ce texte est une traduction officieuse en français du contrat de licence d’utilisation du logiciel CAMINO. Cette traduction des conditions de licence de la présente copie de CAMINO n’a pas de valeur juridique, celle-ci est l’exclusivité de l’original en anglais. Toutefois, nous espérons que cette traduction aidera les utilisateurs francophones à mieux comprendre le contrat de licence d’utilisation du logiciel CAMINO.

##ITALIAN
(1)
Stai per installare Camino. Se accetti i termini di questa licenza, fai clic su “Accetto” per installare il software. Altrimenti fai clic su “Rifiuto”.
(2)
Questa è una traduzione non ufficiale in italiano dell'Accordo di Licenza per l'Utente Finale (EULA) di CAMINO. Essa non ha valore legale nel definire i termini di licenza di questa copia di CAMINO - solo il testo originale in inglese della EULA, qui incluso, ha valore legale. Tuttavia ci auguriamo che questa traduzione possa aiutare le persone di lingua italiana a comprendere meglio la EULA di CAMINO.
(Reporter)

Comment 2

11 years ago
This bug should be closed only when the corrections have landed both on Camino Code AND on the latest Multilingual package available.
Are you expecting updates for Spanish, Japanese, Korean, Simplified and Traditional Chinese, too, or just the 3 you have provided now?

I doubt we'll respin 1.5 just for this change, but if there's a patch and we have to do another respin for Gecko (which seems unlikely, but you never know), we can get this as a ride-along.  Otherwise, definitely for 1.5.1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: camino1.5.1?
(Reporter)

Comment 4

11 years ago
OK for me for 1.5.1.
I expect updates for all languages except Chinese, at the moment.
(Reporter)

Updated

11 years ago
Summary: Corrections to localized Chrome strings in Camino DMG → [l10n] Corrections to localized Chrome strings in Camino DMG
Marcello, any update on getting these for the other languages?
Assignee: qa-mozilla → nobody
Marcello, we're planning on releasing 1.5.1 in the next couple of weeks; if we're going to include these, we need to get the remaining ones ASAP so we can land them with the rest of the fixes.
(Assignee)

Comment 7

11 years ago
I'll handle the landings of updated translations here.  We'll take whatever updates we have available to us during the prep-for-1.5.1 time, which is pretty much now, so if there's anything else, please post it here.
Assignee: nobody → mark
(Assignee)

Comment 8

11 years ago
Marcello, the quotation mark styles in the new text in comment 1 don't match the EULA text.  Guidance?  Above, everything uses “…” style.  In the EULA, de uses „…" and fr uses «…».  (it does use the “…” style.)
(Reporter)

Comment 9

11 years ago
Actually we did'n touch the EULA. And IIRC the typographic quotation style was agreed upon with Smokey on Camil10n list
We agreed to use native smart-quotes, which to me means that the quotes in the German and French passages in comment 1 are wrong.
(Reporter)

Comment 11

11 years ago
(In reply to comment #10)
> We agreed to use native smart-quotes, which to me means that the quotes in the
> German and French passages in comment 1 are wrong.

Which quotes are you referring to? The double quotes look the same across the three examples, and they're smart. The single quotes (apostrophes) look the same as well (German doesn't have them), and they're NOT smart, save one in French.
So I guess I have to fix also Italian.

Anyway, I think Mark was referring to the mismatch between the strings that we touched (those in comment 1) and the ones inside the EULA (which we didn't touch). Looks like the translations weren't checked to make them look the same.
Maybe "smart" is the wrong term.  "Typographic quotes appropriate for the language" was what I thought we agreed upon, but maybe that's not what I ended up saying.

http://en.wikipedia.org/wiki/Quotation_mark,_non-English_usage

I've certainly always seen „…“ for de and «…» for fr in more formal usage. 
(Assignee)

Comment 13

11 years ago
Right, both of you've got the right idea.  Are we going to use „de“ and « fr » in these updated strings?
(Reporter)

Comment 14

11 years ago
I've checked the italian guidelines in the table Smokey (thank you!) pointed at against several books on my shelves. I can say from my sampling, that usage varies a lot. Generally speaking, it seems that those guidelines apply to fictional books or to books published by very "traditional" publishers. Most of my technical books  have "international English style" smart quotes.

My favourite solution is to have a single guideline for all languages, but I'm ok also with the "localized" quotes, as long we're sure that typing them is not too esoteric on local keyboards (my keys combinations for the "right" quotes are alt-1 and alt-shift-1)
(Assignee)

Updated

11 years ago
Flags: camino1.5.1? → camino1.5.1+

Comment 15

11 years ago
I personally would prefer a localized version of quotes.
Many German webpages and applications use the english ("…") quotes, but the German ones („…“) look more professional to me. Even its like Marcello has found out for the Italian language: native quotes are often used by more "traditional" publishers.
From my point of view „Zitat“ looks better than "Zitat" (Zitat means quote).


Another issue:
The German text in comment one, is this the one which will be used?
If so: please take my corrected version. I also included native quotes. I only made changes to (1).
If not, please send me the German text that was supposed to be used because the one above and the one in the ML package have a major grammatical issue.



##GERMAN
(1)
Klicken Sie auf „Akzeptieren“, wenn Sie mit den Bestimmungen des
Software-Lizenzvertrags einverstanden sind.
Falls nicht, klicken Sie bitte auf „Ablehnen“. Die Software kann nur
installiert werden, wenn Sie den Software-Lizenzvertrag akzeptieren.
(2)
Dies ist eine inoffizielle Übersetzung der CAMINO EULA ins Deutsche. Die
Vertragsbedingungen für diese Kopie von CAMINO sind darin nicht gesetzlich
festgelegt, für eine gültige Interpretation ist ausschließlich die
nachstehend angeführte englische EULA-Originalversion heranzuziehen. Wir
hoffen jedoch, dass diese Übersetzung zu einem besseren Verständnis der
CAMINO EULA für alle deutschsprachigen Nutzer beitragen wird.
(Reporter)

Comment 16

11 years ago
Here's the Italian "traditional" quotation style:

(1)
Stai per installare Camino. Se accetti i termini di questa licenza, fai clic su
«Accetto» per installare il software. Altrimenti fai clic su «Rifiuto».
(2)
Questa è una traduzione non ufficiale in italiano dell’Accordo di Licenza per
l’Utente Finale (EULA) di CAMINO. Essa non ha valore legale nel definire i
termini di licenza di questa copia di CAMINO - solo il testo originale in
inglese della EULA, qui incluso, ha valore legale. Tuttavia ci auguriamo che
questa traduzione possa aiutare le persone di lingua italiana a comprendere
meglio la EULA di CAMINO.
(Assignee)

Comment 17

11 years ago
Created attachment 274195 [details] [diff] [review]
Patch for license.r

I couldn't use the entire new instructional string (1) for French, Rez claims that it's a Pascal string and what's been proposed is 25 characters too long.  I've removed the second sentence, which is the one that asks the user to read the license agreement.

I used the German translation from comment 15, and everything else from comment 1, except the French quotes were changed to « this ».

I've also fixed up the rest of the quotation marks in the German EULA body text.
Attachment #274195 - Flags: review?(alqahira)
(Assignee)

Comment 18

11 years ago
Created attachment 274196 [details]
license.r itself

(Just in case patch gets a little loopy with the stuff outside of 7-bit ASCII.)
(Assignee)

Comment 19

11 years ago
(In reply to comment #16)

Marcello, if you want to change to «this» for Italian, we should also fix up the EULA body for consistency.  The current Italian text came from http://www.mozilla.com/en-US/legal/eula/firefox-it.txt, which uses “this” style.  You're our resident Italian expert, so it's your call.  I just don't want to mix quotation styles for a single language in the license dialog.
(Reporter)

Comment 20

11 years ago
As I said before, I'm ok with both solutions. If we decide to go with regular quotation style, I'd like Italian to be consistent with that.

Based on what I read in the EULA translation, I don't believe it was written by a native Italian speaker, so it's understandable that it has an "international" style. Bottom line, if we go with the "formal" quotes, I think it's better to fix the EULA, too (which we didn't change for legal reasons, but I believe it's ok to fix quotes).
Comment on attachment 274195 [details] [diff] [review]
Patch for license.r

Not our bugs, but I noticed in the Italian license

NON DEVE CLICCARE IL TASTO ‘‘ACCETTO’’

should of course be 

NON DEVE CLICCARE IL TASTO “ACCETTO”

and 

(collettivamente”Licenze Open Source”)

should be 

(collettivamente “Licenze Open Source”)


Also not our bug, but I noticed the button names in the license text (used twice in that paragraph) don't match the actual buttons in some cases:

Fr: license is J’accepte; Mac OS X uses Accepter

De: license is Einverstanden; Mac OS X uses Akzeptieren

Jp: license is  同意する (Accept); Mac OS X uses 同意します

I can't find the button names in the license in either Chinese version.  Korean is identical, except the license appends an "(ACCEPT) to the name again.  English and Italian are identical.

r=ardissone with or without those changes (we can file another bug on them if you don't want to fix them now)
Attachment #274195 - Flags: review?(alqahira) → review+

Comment 22

11 years ago
I don't think the differences in the button names are important.
In the German license both types (Einverstanden and Akzeptieren) mean exactly the same and I don't think any judge will point at the different words used for the same meaning. The intention is too obvious!
Further on the license says, that you automatically accept it when installing or using Camino.
But, to be on the save side, we could add the small word "für" before „Einverstanden“. Then you have to click the button that lets you accept the license and not the button that says "Accept".
The changed text would be:

DURCH DRÜCKEN DES SYMBOLS FÜR „EINVERSTANDEN" ODER DURCH INSTALLATION ODER NUTZUNG DES CAMINO BROWSERS ERKENNEN SIE DIE IN DIESER VEREINBARUNG FESTGELEGTEN BEDINGUNGEN AN. WENN SIE SICH MIT DEN BEDINGUNGEN DIESER VEREINBARUNG NICHT EINVERSTANDEN ERKLÄREN, KLICKEN SIE NICHT AUF DAS SYMBOL FÜR „EINVERSTANDEN" UND INSTALLIEREN ODER NUTZEN SIE WEDER DEN CAMINO BROWSER NOCH TEILE DAVON.


But as I said, I don't think changes are needed, if we are allowed to do so.
By the way, I think we should do these changes in accordance with the mozilla team so both projects use the same license.
(Assignee)

Comment 23

11 years ago
Tobias, your suspicion is correct: since that text comes out of the Mozilla license verbatim, we should get it changed there.  I'm reluctant to start making custom localization changes to the text we're taking from them, other than the obvious changes needed to turn Firefoxes into Caminos.
(Assignee)

Comment 24

11 years ago
The new license.r file was checked in (in the same form as it was attached here) for 1.5.x (x>=1), 1.6, and trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1.7
Whiteboard: [camino-1.5.1]
You need to log in before you can comment on or make changes to this bug.