Closed Bug 382144 Opened 16 years ago Closed 14 years ago

Button too close to text field in <input type="file">

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 266229

People

(Reporter: alqahira, Unassigned)

References

Details

(Keywords: testcase)

Attachments

(3 files)

Attached file testcase
With the current trunk Aqua widgets, the button is touching the input textfield in an <input type="file">.  It looks bad.  

I'm not sure when this regressed in the Aqua widget rewrite, but I noticed it the other day in my sweep through form controls testcases.

Camino used less space than Safari did (Safari just shows text, not an input); I suppose we might want to match Safari's spacing, but even Camino's smaller amount of spacing looks much better than what we have on the trunk now.
Attached image screenshot
Today's Minefield, Safari, Camino 1.5
For reference, latest WebKit build
The distance between the button and the textfield is 6px, whereas Safari 1.3/2.0 has 10px.
See also bug #266229
This happens in Firefox 2 on Mac OS X, Linux trunk, Mac OS X trunk. This is just how gecko does it, it is not a Mac OS X widget bug or regression on any OS. Camino 1.5.x and prior used crazy CSS that is diverged from Gecko, that is gone now.

Moving to layout as a UI change request, layout can mark it WONTFIX if they wish.
Assignee: joshmoz → nobody
Component: Widget: Cocoa → Layout: Form Controls
Keywords: regression
OS: Mac OS X → All
QA Contact: cocoa → layout.form-controls
Hardware: Macintosh → All
(In reply to comment #4)
> Camino 1.5.x and prior used crazy CSS that is diverged from Gecko, that is
> gone now.

So its a dup.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 266229
You need to log in before you can comment on or make changes to this bug.