Can't upload PNG files with Special:Upload

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: Benoit, Assigned: reed)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
I've tried several times today to upload a PNG file on the French MDC, but it didn't work. I got a message (in French) saying something like "This file is corrupt, has a null size or has an invalid extension. Please check the file."

I then tried with a smaller file, same result. On the English MDC, same result.

Eventually, I tried with the same image encoded in the GIF format, and it worked. 

If a new test on the file extension was added with the MediaWiki upgrade, maybe PNG has been forgotten in the process?

Comment 1

11 years ago
this bug causes critical problem on -ja,, please fix asap :p
of cource, we can upload via jpeg format, image quality will be decrease.. (for like captures of ui, transformed from -en version directry.)

with reading mediawiki source, problem might be caused with one of following mis-configulation.
1. misconfigulation on finfo : environment value MAGIC not point to valid data file
2. (might be ultla-c, and should not do) set $wgVerifyMimeType to false.

of cource other reasons may exist,, but i could not find.
Confirming, over to ops for help getting it resolved.
Assignee: nobody → server-ops
Component: Infrastructure → Server Operations
Product: Mozilla Developer Center → mozilla.org
QA Contact: infrastructure → justin
Version: unspecified → other
(Assignee)

Updated

11 years ago
Assignee: server-ops → reed
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 3

11 years ago
I think I fixed this, as I have been able to upload two .png files to MDC 'en'. Let me know if the problem occurs again.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 4

11 years ago
ok on -ja wiki, too.
thx.
(Reporter)

Comment 5

11 years ago
I'm still having this problem, both on 'fr' and 'en'. Reopening this bug.

I hadn't tested since the fix, so I don't know if it has regressed or the problem lies in my account -- I see people have been able to upload PNG files as recently as june 29 in the 'en' upload log.
http://developer.mozilla.org/en/docs/index.php?title=Special%3ALog&type=upload
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 6

11 years ago
i couldn't upload .png in 'ja', neither..

so, it's something a regression. :)
(Reporter)

Comment 7

11 years ago
I don't know if it's related, but I've checked the files on the 'en' upload log that have been uploaded since. The upload seems to have worked, but they aren't showing in the articles (their size is 0×0)

See for example http://developer.mozilla.org/en/docs/Image:buttons1.png -- it doesn't show on its image page nor in http://developer.mozilla.org/en/docs/XUL_Tutorial:Adding_Buttons#Some_examples_of_buttons even though the image is on the server: http://developer.mozilla.org/wiki-images/en/5/56/buttons1.png
(Assignee)

Comment 8

11 years ago
Swapped it to use an external mime-type detector. Should be working now.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED

Comment 9

11 years ago
i succeeded to upload in 'ja'
thx reed.
(Assignee)

Comment 10

11 years ago
(In reply to comment #7)
> I don't know if it's related, but I've checked the files on the 'en' upload log
> that have been uploaded since. The upload seems to have worked, but they aren't
> showing in the articles (their size is 0×0)

I rebuilt the image metadata records for 'en', which seemed to fix this. If you're seeing it on other language codes, let me know.
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.