avmplus::File.exists return null

VERIFIED DUPLICATE of bug 459284

Status

--
trivial
VERIFIED DUPLICATE of bug 459284
12 years ago
10 years ago

People

(Reporter: zwetan, Unassigned)

Tracking

unspecified
x86
Windows XP
Bug Flags:
flashplayer-triage +

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: avmplus shell 1.0 build cyclone_dschaffe_2007-05-11_15-05

File.exists( anyfilepath ) always return null
when it should return either true or false.

Reproducible: Always

Steps to Reproduce:
1. define bug_File_exists.as
---
import avmplus.File;
trace( File.exists( "unknown.txt" ) );
---

2. compile the as file and run with avmplus or avmplus_sd
Actual Results:  
File.exists function always return null.

Expected Results:  
File.exists function should return true or false

in mozilla/js/tamarin/shell/toplevel.as

the class File define
public native static function exists(filename:String):String;

it should define
public native static function exists(filename:String):Boolean;
(Reporter)

Comment 1

12 years ago
Created attachment 266271 [details] [diff] [review]
simple File.exists patch

the change in itself is simple, but to apply and use it you need to regenerate toplevel.h and toplevel.cpp.

notes:
1. I had to edit /core/XML.as
   to be able to compile global.abc (needed to generate toplevel.h and toplevel.cpp)
2. in avmplus_8.vcproj \core\version.h
   has been replaced by \core\avmplusVersion.h
   (not really pertinent for that diff)
3. toplevel.cpp and toplevel.h are way different than the original
   because I generated the bytecode including all *.as files from 1 scripts
   (I didn't get how to generate the bytecode from different scripts ...)

Comment 2

11 years ago
Transfer Bug from Core->Tamarin to Tamarin Product.
Status: UNCONFIRMED → NEW
Component: Tamarin → Virtual Machine
Ever confirmed: true
Product: Core → Tamarin

Comment 3

11 years ago
*** This bug has been confirmed by popular vote. ***

Comment 4

10 years ago
Bug 459284 is the same issue and has already been RESOLVED/FIXED so closing this issue as a duplicate even though it was in here first.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: flashplayer-triage+
Resolution: --- → DUPLICATE
Duplicate of bug: 459284

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.