Closed Bug 382262 Opened 13 years ago Closed 12 years ago

"ASSERTION: Event listener manager hash not empty at shutdown!" with -moz-column-count and float

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, memory-leak, testcase, Whiteboard: [dbaron-1.9:Rs])

Attachments

(1 file)

Loading the testcase (in Mac trunk debug) and then quitting triggers:

###!!! ASSERTION: Event listener manager hash not empty at shutdown!: 'sEventListenerManagersHash.entryCount == 0', file mozilla/content/base/src/nsContentUtils.cpp, line 694
Attached file testcase
Chances are we're leaking (content nodes via frames?)
Yeah, we seem to be leaking via the frames created by nsBlockFrame::SplitPlaceholder.

Perhaps we should be asserting somewhere that mOverflowPlaceholders has been emptied?  And see when that assert fails?
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
CCing Eli, who loves floats and -moz-column.
I'd love to fix this, but I can't reproduce :)
Can you reproduce if you add the assertion bz suggested in comment 3?
I have no idea what assertion to add; we already have the following:

nsBlockReflowState::~nsBlockReflowState()
{
  NS_ASSERTION(mOverflowPlaceholders.IsEmpty(),
               "Leaking overflow placeholder frames");
Whiteboard: [dbaron-1.9:Rs]
I can't reproduce this either.

If we were leaking frames we'd get the "Some frame destructors not called" assertion, wouldn't we?
I can't reproduce this any more.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Flags: in-testsuite?
Crashtest checked in.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.