reload times differ between 'reload' button and re-entering the URL

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: ittayd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070320 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070320 Firefox/2.0.0.3

See for example http://www.mediawiki.org/wiki/MediaWiki, but this behaves the same with other sites

- type http://www.mediawiki.org/wiki/MediaWiki into the URL bar. page loads making 26 requests (seen with firebug)
- put the cursor in the url bar and just hit enter. page loads making 17 requests. 0.7 seconds to load
- hit 'reload' (no shift or anything like that). page loads making 26 requests. 4.16 seconds to load

In other sites, where caching is more tuned, this is much worse:
- in cnn.com, first time access makes 199 requests, hitting the url again makes 35 requests (5.2 seconds), 'reload' makes 191 (13.2 seconds) requests

Same behavior in -safe-mode and new profile

I think reload should be the same as re-entering the URL. If I want to truely reload everything (because I'm a site developer), I can do this with shift-reload.

Note: the revalidate Cache-Control directive is not the issue here, other sites that don't use this show the same behavior


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Reload is not the same and should not be.

Loading it again = load from the cache if the document freshness permits it
reload = asks the server if the cache document is still the same
shift+reload= throw away the cache and load the document again from the server

This is by design
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.