Closed Bug 382482 Opened 13 years ago Closed 13 years ago

Error when accessing navigator.offlineResources (NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)

Categories

(Core :: DOM: Core & HTML, defect)

x86
All
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: cbook, Assigned: dcamp)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

After login in Zimbra i get only a lightblue background and no webmail interface, see Screenshot.

The Error Console show as Error:
Error: [Exception... "Cannot find interface information for parameter arg 0 [nsIDOMClientInformation.offlineResources]"  nsresult: "0x80570006 (NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)"  location: "JS frame :: https://mail.mozilla.com/zimbra/js/Ajax_all.js.zgz?v=(session id removed) :: anonymous :: line 22755"  data: no]
Source File: https://mail.mozilla.com/zimbra/js/Ajax_all.js.zgz?v=(session id removed)
Line: 22755

This regressed between:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/2007052904 Minefield/3.0a5pre and 
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/2007052804 Minefield/3.0a5pre

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-05-29+04%3A00%3A00&maxdate=2007-05-28+04%3A00%3A00&cvsroot=%2Fcvsroot

I think this could be a regression of Bug 372970.
Flags: blocking-firefox3?
Component: General → DOM
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → general
Changing OS -> All since i see the same on Fedora FC 6 and restoring lost blocking request.
Flags: blocking1.9?
OS: Windows Vista → All
This occurs when anything tries to access navigator.offlineResources:

javascript:for (var i in navigator) { document.writeln(i + "<br>"); document.writeln(typeof(navigator[i]) + "<br>"); }
Summary: Interface lost after login in mail.mozilla.com webinterface (NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO) → Error when accessing navigator.offlineResources (NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)
Blocks: 372970
Flags: in-testsuite?
Probably just need to add dom_offline.xpt to the installer manifests. See for examle: http://mxr.mozilla.org/seamonkey/search?string=dom_base.xpt
This patch puts dom_offline.xpt wherever there was a dom_base.xpt, except the xcode projects.  I can figure out how to do that separately, but I thought I'd put this up for now.
Assignee: nobody → dcamp
Status: NEW → ASSIGNED
Comment on attachment 267201 [details] [diff] [review]
scatter dom_offline.xpt around the tree

r/sr+ for 1.9 drivers
Attachment #267201 - Flags: superreview+
Attachment #267201 - Flags: review+
FYI, this isn't broken on Mac due to how the packaging process works there.  We should file a follow up on making Win32 (and Linux?) packaging work more like that, with just an exclusion list of files not to package, to prevent developers from making this error over and over again.
I just tested this using the RC2 candidate build on Fedora Core 7. If you click shaver's URL you get this error in the console: 
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMClientInformation.offlineResources]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: javascript:for (var i in navigator) { document.writeln(i + "<br>"); document.writeln(typeof(navigator[i]) + "<br>"); } :: <TOP_LEVEL> :: line 1"  data: no]
Same exact error on Debian Etch with the RC2 candidate:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMClientInformation.offlineResources]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: javascript:for (var i in navigator) { document.writeln(i + "<br>"); document.writeln(typeof(navigator[i]) + "<br>"); } :: <TOP_LEVEL> :: line 1"  data: no]
So fwiw that's actually a different error, that seems to not break zimbra for me.  I'm looking in to it.
offlineResources fails to initialize if there's no host in the uri.  So when loaded from a javascript: uri it will fail, but it's fine from an http document. I'll file a separate bug for the javascript: thing.
This is fixed, then. ->FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
verified fixed on Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a6pre) Gecko/20070606 Minefield/3.0a6pre ID:2007060604 [cairo]

also on Linux and Gran Paradiso 1.9a5 RC 2.

Zimbra works as expected and is full usuable -> Changing to Verified Fixed.
Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.