Firefox 2.0.0.4 for Windows does not complete startup--it hangs and can't be aborted by task manager.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: archie.strong, Unassigned)

Tracking

({hang})

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Firefox for Windows 2.0.0.3 reported a security patch.  I gave it the okay to update.  When I exited and tried to restart, nothing happened.  I checked with Task Manager and found that Firefox.exe was present as a task, but not consuming any CPU time.  I tried to terminate it, and it still hung around.  I restarted Windows (XP Pro SP2 with security patches applied) and tried again.  It still behaved the same, so I rebooted and uninstalled Firefox 2.0.0.3.  Oddly enough, 2.0.0.4 was not listed, but 2.0.0.2 and 2.0.0.3 were, in the Windows Add/Remove Programs list.  I discovered I only had 2.0.0.1's install program in my downloads, so I installed it.  Things worked until I retried the update.  Same problem once it was updated, so I took it out again.  Then I downloaded the latest SeaMonkey install (2.0a1pre), ran it and tried to bring it up.  Same problem!  I am using Firefox 2.0.0.1 at the moment, since I have things to do (plane tickets to buy to see my grandson (;)).



Reproducible: Always

Steps to Reproduce:
1.Install Firefox 2.0.0.4 on my machine
2.Start Firefox
3.Bring up Task Manager
Actual Results:  
I observed that Firefox was listed as an active task, but it was not consuming any CPU time.  Firefox never finished starting.

Expected Results:  
Brought up the browser.

Note that I have Macafee Security Firewall installed, but this problem happens when I disable the firewall, so I know it isn't the problem.  I also uninstalled the SiteAdviser addon, so it isn't involved.  Besides, this was working until 2.0.0.4 was installed!
(Reporter)

Updated

12 years ago
Keywords: hang
I once had a firewall that prohibited Firefox from accessing the internet even after I uninstalled it fully. 

Does it also happen when you install Firefox on your desktop and start it from there? If so, you have either a very smart firewall or there is something wrong in your profile. It that case you could try creating a new profile.

http://kb.mozillazine.org/Profile_Folder
(Reporter)

Comment 2

12 years ago
I am puzzled by the fact that Firefox does not put up any messages--just sits there doing nothing, as evidenced by the task manager.  I will try creating a new profile, but remember this profile works with every version of Firefox before the 2.0.0.4 patch.
(Reporter)

Comment 3

12 years ago
Creating a new profile did not improve things one bit.  I first created a clean profile with 2.0.0.1, and verified that starting Firefox starts the profile manager, since I unclicked the do not ask at startup box.  Then I installed 2.0.0.4, and tried to run firefox.exe -ProfileManager from command prompt (just to play it safe).  Firefox still hung and was not abortable.  In fact, it seemed to put Windows into limbo, since telling Task Manager to restart the system failed to do so.  I had to hit the reset button, which did work.  By the way, this occurred while my firewall was disabled and no other programs (including webshot and BOINC) were running in the background.  

Let me repeat:  Firefox 2.0.0.3 and 2.0.0.1 both worked with nothing else different, whereas 2.0.0.4 does not complete its startup process.  The firefox.exe task is still present, but seems to not be using any CPU.

With the 2.0.0.4 patch, does firefox attempt to connect to the internet before it even puts up a window?  I have a router which has some firewall ability (NAT and SPI), which does not prevent any of the earlier versions of Firefox from working, but maybe something changed in the latest version?  (it is a NETGEAR 54 MBPS Wireless router with four wired ports--WGR614)  I could get a Net Monitor trace, if anyone thinks it might help.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 4

12 years ago
The problem has been eliminated, although I am unsure what the heck happened.  I uninstalled the McAffee firewall, downloaded the Firefox 2.0.0.3 install--found it on the Mozilla Firefox download site (just changed the link to use 2.0.0.3 instead of 2.0.0.4).  Then I installed 2.0.0.3 and finally ran the update to go to 2.0.0.4.  It worked.  Now I'll try installing McAffee firewall again, and see if it is willing to learn to allow 2.0.0.4 to startup.  More to come...
(Reporter)

Comment 5

12 years ago
Well, reinstalling McAffee required uninstalling all of McAffee's goodies--I couldn't get the d*** install program to prompt me for my serial number!  After all that, I now have a working 2.0.0.4 Firefox and McAffee Firewall--again.

SO..mark this fixed.  Something in the latest Firefox clashed with a pre-existing McAffee firewall, but reinstalling the firewall got past it.  God, isn't Windows wonderful?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You could also try another (freeware) firewall. At the moment I have an old Kerio that works perfectly, it's just notifies you after every update when you start the browser. Also Sygate worked fine, two years ago when I tried it. The people at http://forums.mozillazine.org/viewforum.php?f=38 can advise you.
FIXED is not the appropriate resolution in this case, changing to WORKSFORME.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.