[trunk][vista] Access violation in nsmsgdbview.cpp [@ nsMsgDBView::ListIdsInThreadOrder]

RESOLVED DUPLICATE of bug 382640

Status

MailNews Core
Database
--
critical
RESOLVED DUPLICATE of bug 382640
11 years ago
7 years ago

People

(Reporter: Frederic Bezies, Assigned: Bienvenu)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070530 Minefield/3.0a5pre
Build Identifier: 

I am facing a lot of crashes since last update of Thunderbird (30 may update).

Every single time I try to look at newsgroup, thunderbird crash.

It seems to be related to a problem with nsmsgdbview.cpp in line 4553. Don't know which patch is guilty for that crash :(

Some talkback ID :

TB32694150X
TB32684730Y
TB32684725Y
TB32684711Y
TB32684699Q

Reproducible: Always

Steps to Reproduce:
1.Use a 30 may 2007 Thunderbird trunk build
2.Try to open a group
3.
Actual Results:  
Thunderbird just crash

Expected Results:  
Seeing message ?

Besides TalkbackID, no other info to offer.

Comment 1

11 years ago
Incident ID: 32694150 
Stack Signature nsMsgDBView::ListIdsInThreadOrder d6bc5464 
Product ID ThunderbirdTrunk 
Build ID 2007053003 
Trigger Time 2007-05-31 05:26:21.0 
Platform Win32 
Operating System Windows NT 6.0 build 6000 
Module thunderbird.exe + (004e35a6) 
URL visited  
User Comments trying to read newsgroup. 
Since Last Crash 181 sec 
Total Uptime 226 sec 
Trigger Reason Access violation 
Source File, Line No. d:\builds\tinderbox\tb-trunk\winnt_5.2_depend\mozilla\mailnews\base\src\nsmsgdbview.cpp, line 4553 
Stack Trace  

nsMsgDBView::ListIdsInThreadOrder  [mozilla/mailnews/base/src/nsmsgdbview.cpp, line 4553]
nsMsgDBView::ListIdsInThread  [mozilla/mailnews/base/src/nsmsgdbview.cpp, line 4603]
nsMsgDBView::ExpandByIndex  [mozilla/mailnews/base/src/nsmsgdbview.cpp, line 4199]
nsMsgDBView::FindKey  [mozilla/mailnews/base/src/nsmsgdbview.cpp, line 3970]
nsMsgDBView::FindFirstNew  [mozilla/mailnews/base/src/nsmsgdbview.cpp, line 5378]
nsMsgDBView::NavigateFromPos  [mozilla/mailnews/base/src/nsmsgdbview.cpp, line 5091]
nsMsgDBView::ViewNavigate  [mozilla/mailnews/base/src/nsmsgdbview.cpp, line 5034]
NS_InvokeByIndex_P  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2229]
Assignee: mscott → bienvenu
Component: General → MailNews: Database
Keywords: crash
Product: Thunderbird → Core
QA Contact: general → database
Summary: [trunk][vista] Access violation in nsmsgdbview.cpp → [trunk][vista] Access violation in nsmsgdbview.cpp [@ nsMsgDBView::ListIdsInThreadOrder]

Comment 2

11 years ago
2689 mscott         1.8     rv = m_db->EnumerateMessages(getter_AddRefs(enumerator));
2690                        if (NS_SUCCEEDED(rv) && enumerator)

4545                        threadHdr->EnumerateMessages(parentKey, getter_AddRefs(msgEnumerator)); 
4553 bienvenu       1.60    while (NS_SUCCEEDED(rv) && NS_SUCCEEDED(rv = msgEnumerator->HasMoreElements(&hasMore)) && hasMore)

This would be the obvious reason.
nsIMsgThread::EnumerateMessages failing all the time was fixed in bug 382441 so the missing check won't be hit much now

Comment 4

11 years ago
I think this is fixed by my patch in Bug 382640
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382640
Product: Core → MailNews Core
Crash Signature: [@ nsMsgDBView::ListIdsInThreadOrder]
You need to log in before you can comment on or make changes to this bug.