Closed Bug 3826 Opened 21 years ago Closed 21 years ago

[BETA][FEATURE] Partial about: implementation

Categories

(SeaMonkey :: UI Design, defect, P2)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rickg, Assigned: davidm)

References

Details

(Whiteboard: Has this already been implemented by the Necko team?)

Entering "about:" in the location field does not trigger the
reporting of the version. The build was a .zip file 2544 MB in size, copied c.
0130 PST of Tuesday, March 16, and is currently (0926 PST, March 16) available
at ftp://ftp.mozilla.org/pub/mozilla/nightly/last-built/ .
This bug is consistent, and is reproducible under any circumstances on this
machine.
Target Milestone: M4
Changed target milestone to M4.
Target Milestone: M4 → M7
Changed target milestone to M7.
QA Contact: leger → claudius
*** Bug 4010 has been marked as a duplicate of this bug. ***
Hardware: PC → All
Component: Apprunner → XPApps
Target Milestone: M7 → M10
Matt is scheduled to do this for M10, but I'll hold onto it for now.
*** Bug 6000 has been marked as a duplicate of this bug. ***
This is an essential feature...  Especially the about:mozilla part!
Blocks: 10980
Summary: about: does not work → [FEATURE] Partial about: implementation
We need to do just enough of this for the first public release ...
Whiteboard: Has this already been implemented by the Necko team?
Target Milestone: M10 → M11
Assignee: don → davidm
Target Milestone: M11 → M10
David, find out if the Necko team has implemented enough of this to not not
suck, i.e. enough so "about:" at least tells you which version of the product
you're running.
Blocks: 12659
Priority: P3 → P2
Summary: [FEATURE] Partial about: implementation → [BETA][FEATURE] Partial about: implementation
Target Milestone: M10 → M11
David, any update?
Necko has some arch. I assume it would be pretty easy to plugin and load a web
page but I really haven't looked at it much. Most of the time will be spent
figuring out Necko terminology.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
basic about: checked in. about.html can be update to reflect whatever the final
wordings turn out to be
Status: RESOLVED → VERIFIED
If all we are asking for here is one types about: and gets served a page with
content we control then yes it works. marking VERIFIED with 19990913 builds
Target Milestone: M11 → M10
resummarizing to be clear, 
will file mozilla version of this bug.
Summary: [BETA][FEATURE] Partial about: implementation → [BETA][FEATURE] Make the Netscape about: page legal
wrong bug, sorry
Summary: [BETA][FEATURE] Make the Netscape about: page legal → [BETA][FEATURE] Partial about: implementation
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.