Caret erases parts of characters

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
11 years ago
a year ago

People

(Reporter: Aaron Leventhal, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
If the caret overlaps part of the character that it is not positioned on, then it will often erase part of that character (depending on where it was in the blink cycle).

1. Load the attached testcase font-change.html
2. Toggle on caret browsing with F7 (you can turn it off with the same key)
3. Click in the text and arrow to "g" and then arrow somewhere else

Half the time a piece of "f" will be erased.
(Reporter)

Comment 1

11 years ago
A related problem leaves huge chunks of characters on the screen.
1. Go to http://www.mozilla.org/editor/midasdemo/
2. In the editor, select font size 7
3. Type "ffffffffffff" and then start backspacing. A very large "turd" will be left from some of the f's
(Reporter)

Comment 2

11 years ago
I'm able to reproduce the problem in comment 1 in both Firefox 2 and Thunderbird 2. Therefore that part is likely a duplicate of some other bug.

However, the caret problem is new -- perhaps due to the fact that the caret is drawn as a solid block now?
This depends on the bug about giving text frames overflow (and about reporting such overflow from the font code), which I think roc has been working on recently; I suspect it's a duplicate of some of that bug's existing dependencies.
Depends on: 96041

Comment 4

9 years ago
In current nightly I can still reproduce it but only selecting
Courier + Italic

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20081007 Minefield/3.1b1pre

Comment 5

7 years ago
(In reply to comment #4)
> In current nightly I can still reproduce it but only selecting
> Courier + Italic

still reproduces per above with Mozilla/5.0 (Windows; Windows NT 6.0; rv:2.0b3pre) Gecko/20100724 Minefield/4.0b3pre (.NET CLR 3.5.30729)
Severity: major → normal
Tested in latest Release and Nightly and could not reproduce the errors
Version 	46.0.1
Build ID 	20160502172042
Version 	49.0a1
Build ID 	20160519030232
I will close as Resolved-WFM
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.