SVG ignores Superscript, Subscript, Underline

RESOLVED DUPLICATE of bug 308338

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 308338
11 years ago
11 years ago

People

(Reporter: Glenn Howes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/419 (KHTML, like Gecko) Safari/419.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a5pre) Gecko/20070531 Minefield/3.0a5pre

tspan elements in SVG with properties: baseline-shift="super", baseline-shift="sub" and text-decoration="underline" are ignored. 

The example file should have H2SO4 with the 2 and 4 subscripted, and He+ with the + superscripted. 
All text in the example file should be underlined. 

To see it render properly, view in Opera.

Reproducible: Always

Steps to Reproduce:
1. Load the example file
Actual Results:  
The 2, 4 and + are at the same baseline as the rest of the text
The text is not underlined

Expected Results:  
The 2 and 4 should be subscripted relative to the other text in their line.
The + should be superscripted relative to He
All the text should be underlined.
Component: General → SVG
Product: Firefox → Core
QA Contact: general → general
underline not implemented is bug 317196 and baseline-shift not implemented is bug 308338
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 308338
You need to log in before you can comment on or make changes to this bug.