If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Message filter doesn't work for a custom header

RESOLVED DUPLICATE of bug 184490

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 184490
11 years ago
11 years ago

People

(Reporter: Borja Martín, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: versión 2.0.0.0 (20070326)

If you try to create a message filter by defining a custom header, it seems that Thunderbird just ignores it and doesn't do anything with the message.

Reproducible: Always

Steps to Reproduce:
1. Open the Message Filters windows and create a new one
2. Select the customize option for the message header
3. Add the new header(List-Id, for example)
4. Select the new option from the drowdown menu
5. Fill the rest of the input fields and say to move the found messages to another folder as the action/s to be performed
6. Click on the Ok button and and run the filter
Actual Results:  
Nothing happens although there are messages with the given header

Expected Results:  
The found messages should be moved to the given folder

I tried this on the Linux and Windows version and in the latest nightly build as well. I'am also using an IMAP account and this is the filter I created:
·For incoming messages which:
Match any of the following
List-Id - contains - campusvirtual.uem.es

·Perform these actions:
Move Message to campusvirtual on borjam@dagi3d.net

And this is part of the header of one of the messages I have in my InBox that was supposed to be handled by the filter:
List-Id: "Foro de Noticias" <moodleforum2972@campusvirtual.uem.es>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 184490
You need to log in before you can comment on or make changes to this bug.