justified 100% width textual elements, when print previewed, extend to the right of the page

RESOLVED WORKSFORME

Status

()

Core
Print Preview
--
minor
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: 1212jtraceur, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-06-15])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

A webpage with 100% width justified textual elements, when printed, has text running off the right of the printed pages.

Reproducible: Always

Steps to Reproduce:
1. make a webpage with paragraphs (p elements, containing enough text to fill a line, preferably more than one, when printed).
2. apply these styles to it:
	body p {
		text-align : justify;
		font-size : 16px; // for consistency
		margin : 1em 0; // not necessary, but makes page more legible
		width : 100%;
	}
3. print preview, observe text running off the right of the page
Actual Results:  
text runs off the right of the page

Expected Results:  
text should wrap earlier

can be fixed by reducing the width of the paragraphs, or by not justifying their content text. testcase will be attached.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

11 years ago
Created attachment 266835 [details]
illustrates the justified 100% width text bug. print preview to see bug

Updated

11 years ago
Component: General → Print Preview
Product: Firefox → Core
QA Contact: general → printing
Version: 2.0 Branch → 1.8 Branch

Comment 2

8 years ago
Does this work in version 3.6? 
If it does work, please close the bug and set resolution to WORKSFORME.
If it does not work, please update the bug.

(generally speaking, printing is greatly improved in v3.5 and v3.6)
Whiteboard: [closeme 2010-06-15]

Comment 3

8 years ago
Closing works for me using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8, need response confirming that this is still an issue from reporter to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.