URLS with port numbers don't link - Host not found

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: kevp, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: test case needed, URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.10 i686; en-US; m15)
BuildID:    2000042621

At work we have several test servers that do not run on port 80, so we have host
names with a :8080 etc.. on the end. With these, a value entered in to the URL
box at the top will work but none of the relative links with the fetched page
work. They all give host unknown.

Reproducible: Always
Steps to Reproduce:
1.Go to URL
2.Try a link.
3.

Actual Results:  Host not found error appears

Expected Results:  Fetches the required link
We're going to need a test server on the internet to check this...
Whiteboard: test case needed
http://atlas.esrin.esa.it:8000/ is an example, and the links there work fine in
a current (2000-05-03-08) linux nightly build.

Comment 3

18 years ago
does this happen only when you leave off the http://, or does it always happen?

Comment 4

18 years ago
http://atlas.esrin.esa.it:8000/ on 2000050412 under linux WORKSFORME also.

kevp@nipltd.com - can you confirm that this is still occuring with a later
build.  If so, is it possible to post a non-sensitive html document, with the
url you are using to call it as a test case?  (Suspect BASE HREF is not set at
the moment).

Recommend WORKSFORME.
(Reporter)

Comment 5

18 years ago
Made a few more tests and further investigation here.. Seems to be more
of a re-direct problem. Most of the URL get re-directed with local paths
such as http:/new/page/stuff. This may be the actual problem.

Comment 6

18 years ago
marking worsforme, please open anothe rbug for that redirection thing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
massive update for QA contact.
QA Contact: petersen → lorca
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 9

17 years ago
qa contact updated.
QA Contact: gerardok → bsharma

Comment 10

17 years ago
Verified on:
build: 2001-04-09-11-Mtrunk
Platform: Win 2000

http://atlas.esrin.esa.it:8000/ site loads fine.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.