Attachment icons too big by default

RESOLVED DUPLICATE of bug 511592

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 511592
11 years ago
9 years ago

People

(Reporter: wenzel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

11 years ago
The most common question people ask me about Thunderbird 2 is "how do I make the attachment icons smaller again?".

While there is a workaround (http://ilias.ca/blog/2007/04/small-attachment-icons-in-thunderbird-2/), it involves the config editor, which is hardly "Mom-friendly".

I get the impression the large icons annoy more people than they please, so you may either want to set the default to small or give them a more easily findable config option.

Thoughts?

Comment 1

11 years ago
What about automatically toggling that option when the user resizes the attachments pane? Make the icons smaller onoverflow and bigger onunderflow, so there's no need for additional UI and users can make the change right where they're annoyed.

This would of course involve actually applying the change instantly (currently the modifying the pref seems to affect only new windows).

OTOH: Just because a few (dozen, hundred, thousand?) people complain there's not necessarily reason for a change. First a majority of users might take advantage of the current state without being aware (the icons are bigger and thus easier to hit - but who would speak out over this?); and second adding UI to make a vocal minority shut up is one of the main causes for UI bloat (and is usually an indication of devs not being sure of a decision and thus moving the burden over to the user).
(Reporter)

Comment 2

11 years ago
The automatic toggling sounds like a good idea, if feasible.

But I also agree with you that making those who cry the loudest shut up is a very bad reason to change UI. That's why my initial bug was pretty tentative.

Comment 3

11 years ago
I agree the small icons are nicer...
OS: Windows XP → All
Hardware: PC → All

Comment 4

11 years ago
I would suggest that this is clearly a matter of taste, and therefore clearly a matter for the UI.

I looked in the View menu first, then in the context menu in the attachments pane, then in the Options dialog, then in the advanced config (filter 'icon') then in the help. That's far too much messing around for such a trivial matter, even for a minority, and however vocal it is.

Nearly every entry in the View menu has a sub-menu. Would it really be bloat to turn "Display Attachments Inline" into

Display Attachments =>
   Inline
   ------
   Large Icons
   Small Icons
   No Icons
?

Autosizing would be nice (but then add "Autosize" to the sub-menu), but I imagine just putting the option in the UI would be easier.
Duplicate of this bug: 395695

Comment 6

9 years ago
Decisions should be made on an objective evaluation (yes, it's imperfect) instead of some supposed "vocal minority" or a developer's personal usage habit. Therefore, a list of advantages and disadvantages for large and for small icons (and for auto-switching between them) should be made (although, for me, the small icons are the clear choice). I'll start:

*Large Icons*

Advantages:
- easier to click on
- icon symbol easier to identify (but people can either recognize the small icon easily enough or they simply don't care what application will be opened)

Disadvantages:
- Takes up more vertical space (reducing the message content)
- Filenames often truncated beyond usefulness (long filenames are now very common, especially in business environment)
- Filemanes are below the icon and are thus not left-aligned nor listed beneath each other thus making comparing them (often there are only subtle differences, like a running number) and reading them much more difficult.
- fewer attachments can be shown

*Small Icons*

Advantages:
- more attachments can be shown in same amount of space
- filenames are easier to parse because they are left aligned, below each other, and more of the filename can be shown
- icons are sufficiently recognizable
- icon + filename are large enough to select without error

Disadvantages:
- None

PS. It has always bugged me that Windows XP shows the large icons ("Tiles" view) by default in Explorer (Thunderbird shows the even worse "Icons" view) instead of the much more useful small icons ("List" view). That is one of the many reasons I use Total Commander instead.

Comment 7

9 years ago
Created attachment 391318 [details]
Screenshot of Windows Explorer's "List" view

Comment 8

9 years ago
Created attachment 391319 [details]
Screenshot of Windows Explorer's "Icons" view
Fixed by bug #511592?

Comment 10

9 years ago
IMO: No. See comment #6.

Comment 11

9 years ago
In what way not then? As for auto-switch, i doubt we want to do that.

Comment 12

9 years ago
Vertical space should be optimized for the messages' content. Think about the increasing popularity of Netbooks, which have limited vertical screen resolution. Also, the small icons are usually clear enough as to which program the file was made with. And it's the file-name is what really counts.

So what was the significant benefit of having huge icons?

PS. I agree that we don't need auto-switching (just a better default).

Comment 13

9 years ago
Yeah, but we loose practically no vertical space. Icons are roughly the same height as a line now after bug 511592.

Comment 14

9 years ago
Created attachment 397840 [details]
Screenshot with few attachments

Ah, this seems to be the new look in recent nightly builds: Small icons and only one line tall when there are only a few attachments (~<4). Very nice!

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090831 Lightning/1.0pre Shredder/3.0b4pre

Comment 15

9 years ago
Created attachment 397841 [details]
Screenshot with many attachments

Here is how it looks like with many (10) attachments: The attachments pane expands to show all 10 attachments.

Is there a limit to how tall the attachments pane can get (to not make the message pane un-usable/disappear)? How is the limit defined? In pixels? In percent of available space?

Comment 16

9 years ago
(In reply to comment #15)
> Created an attachment (id=397841) [details]
> Screenshot with many attachments

BTW: Why does a multi-selection (SHIFT+select in "File Upload" dialog)) always place the *last* selected item in that list at the *beginning+ of the resulting list? That's bugged me for years. :-(

Comment 17

9 years ago
(In reply to BTW)
I think this is a stupid general Windows file browser selection problem:
If you simply mark the attachments in revers order (from last to first) it is mostly (not always) ok.

I have noticed this strange behavior in all other programs too (VirtualDub, RegiStax, IrfanView and all video players)

Comment 18

9 years ago
The attachments area is at most 1/4 of the msg pane
http://mxr.mozilla.org/comm-central/source/mail/base/content/msgHdrViewOverlay.js#1557

Anyway, duping.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511592

Comment 19

9 years ago
(In reply to comment #18)
> The attachments area is at most 1/4 of the msg pane

...and can be dragged to be any size (it can even be dragged over the message header - while causing a brief weird resizing of the buttons). :-)
(Reporter)

Comment 20

9 years ago
Woot, fixed :) I guess I should download a nightly build to check it out.
You need to log in before you can comment on or make changes to this bug.