Closed Bug 382854 Opened 15 years ago Closed 15 years ago

Bad link for Croatian dictionary prevents dictionary installation

Categories

(addons.mozilla.org Graveyard :: Administration, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: valent.turkovic, Assigned: wenzel)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070530 Fedora/2.0.0.4-1.fc7 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0

Hi, when trying to install Croatian dictionary from this link:
https://addons.mozilla.org/en-US/firefox/browse/type:3

I get an error.

The link form which Firefox 2.0 tries to install the dictionary is:
https://addons.mozilla.org/en-US/firefox/downloads/file/13906/croatian_dictionary_-_hrvatski_rje%C4%8Dnik-1.0.1-firefox+thunderbird+seamonkey.xpi

and it fails.

Please correct the link to:
https://addons.mozilla.org/en-US/thunderbird/downloads/file/13906/croatian_dictionary_-_hrvatski_rjecnik-1.0.1-firefox+thunderbird+seamonkey.xpi

Thank you.

Reproducible: Always

Steps to Reproduce:
1. Right click / Languages / Add distionaries
2. When page loads click on Croatian dictionary
3. Read failed message
Actual Results:  
Got error message

Expected Results:  
Installed dictionary
Please fix this bad link.
(In reply to comment #1)
> Please fix this bad link.

Yes, it's only bad link. Can someone fix it?
Looks like nobody even looks at these bug reports :(
No, it's not "only" a bad link. Since it's an auto-generated list from the database, we have to find and fix the underlying problem (and write a test for it so it doesn't happen again).
Assignee: nobody → fwenzel
Severity: major → normal
Target Milestone: --- → 3.2
Version: unspecified → 3.0
Sorry for our bad presumption. And thank you for looking into this problem. Is this a mayor issue? How much time do you need to fix this bug?
Sorry for our bad presumption. And thank you for looking into this problem. Is this a mayor issue? How much time do you need to fix this bug?
I am currently writing a patch for it, but it will probably take a few days afterwards until it is actually pushed to the live site.

For your current installation needs you should use the replacement link you mentioned above (which works).
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Oh great! I'll check it out in a week or so to test it.
It seems to work now. If you experience any more problems, feel free to reopen or file a new bug. Thanks!
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Reopening: Apparently the invalid URL was not the only problem. Instead, now an "addon not found" error is triggered.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Uups, now it really doesn't work. I get the same error: "Add-on not found"
Yup, now it's fixed. Sorry for the delay.
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Works great!
Thanks Frederick.
Component: Add-ons → Administration
QA Contact: add-ons → administration
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.