If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird nightly reports "GetLongPathNameW could not be located" on startup

RESOLVED DUPLICATE of bug 330208

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 330208
10 years ago
10 years ago

People

(Reporter: Tom Metro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1
Build Identifier: thunderbird-3.0a1pre.en-US.win32.installer.exe

When trying to start the Thunderbird nightly (thunderbird-3.0a1pre.en-US.win32.installer.exe) just downloaded, on a Windows NT sp6a system, on startup it shows a dialog:

"The procedure entry point GetLongPathNameW could not be located in the dynamic
link library KERNEL32.dll"

Probably an API not supported by NT.

I reported the same issue with Firefox in Bug 382844. (Maybe this should be retargeted to Gecko?)

I reported a similar problem (the entry point was GetLongPathNameA) regarding a
Thunderbird nightly here:
http://forums.mozillazine.org/viewtopic.php?p=2867268#2867268

That was a 2.0 (branch?) nightly: thunderbird-2.0.0.0pre.en-US.win32.installer.exe


Reproducible: Always

Steps to Reproduce:
1. Install nightly.
2. Start application.

Actual Results:  
Error dialog.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379738

Comment 2

10 years ago
Err... actually, this is INVALID. Trunk only supports versions of Windows 2000 or greater.
Resolution: DUPLICATE → INVALID
Well, then it should *say so*! :)
Resolution: INVALID → DUPLICATE
Duplicate of bug: 330208
You need to log in before you can comment on or make changes to this bug.