Mac daily verification build fails

VERIFIED FIXED in M16

Status

SeaMonkey
Build Config
P2
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Jon Granrose, Assigned: J.J. Enser)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
The mac daily verification build is failing to build.  I'll attach the macperl 
and buildnglayout logs to the bug.

This is a blocker for the mac.
(Reporter)

Comment 1

18 years ago
reassigning to jj instead of cls.
Assignee: cls → jj
Priority: P3 → P2
Target Milestone: --- → M16
(Reporter)

Comment 2

18 years ago
Created attachment 8333 [details]
MacPerl Log file
(Reporter)

Comment 3

18 years ago
Created attachment 8334 [details]
Build NG Layout log file

Comment 4

18 years ago
Putting on dogfood+ radar.
Keywords: dogfood
Whiteboard: [dogfood+]
(Reporter)

Comment 5

18 years ago
By doing a "cvs checkout" in the mozilla/mailnews directory followed by a build 
where I didn't delete the existing tree (depend/clobber in mac automation), the 
mozilla build succeeded and the commercial build is still building.

However, I think we still have to discover the root cause of the problem that it 
isn't pulling and/or building everything in mozilla/mailnews.

removing blocker status since we apparently have a workaround.
Severity: blocker → critical
(Assignee)

Comment 6

18 years ago
i just ran the pull section of buildcentral (name of the main verif/tinderbox 
script) and witnessed the same behavior as this morning: no error, no timeout, a 
few warnings (attached screen shot for the record), but mailnews is incomplete 
(see second attachment)
Obviously Tinderboxen don't experience this problem since they're all green at 
the moment.

can anybody else try to run pullnglayout.pl on a fresh tree and see if this can 
be reproduced on a different machine ? I'm running out of ideas.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
Created attachment 8375 [details]
CVS pull warnings
(Assignee)

Comment 8

18 years ago
Created attachment 8376 [details]
mailnews dir content ('public' missing)
(Assignee)

Comment 9

18 years ago
fixed. this is a MacCVS low memory situation. When this happens, MacCVS simply 
stopped pulling "SeaMonleyAll" module before its end. No timeout returned to 
MacPerl, no error in the message window, no alert... I had to trace the build 
script to see this with my own eyes and notice that the free heap was around 50K 
at the time.

Increasing MacCVS memory partition from 5 to 8 MB fixed the problem and the 
entire tree now gets pulled without a glitch.

This is still a mystery to me since all Tinderboxen are configured identically (5 
MB for MacCVS, 256 MB machines) and don't have this problem.

maccvs team: Should I log a separate "MacCVS bug"? Would switching to 2.5 help ?
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

18 years ago
no failure yesterday or today.  verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.