Java applet causes location bar to be unresponsive

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
11 years ago
a year ago

People

(Reporter: ashughes, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
When running the java applet at the provided URL, the location bar becomes unresponsive to mouse clicks or keyboard shortcuts.

This has been experienced on Minefield 3.0a5pre in both Windows XP and Vista.

The only work around I have found is to open a new tab then jump back to the original tab.  This appears to re-enable the location bar.

Steps to reproduce:
1. Open Minefield and navigate to the provided URL
2. Try clicking, double-clicking to put focus on the location bar or try keyboard shortcuts

Actual Results:
Location bar is unresponsive and keyboard shortcuts do not work

Expected Results:
User should be able to put focus on the location bar to navigate to another URL.

Reproducible: Always

Updated

11 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins

Comment 1

11 years ago
Which version of Java are you using?
This ist WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070804 ID:2007070804 and JRE 6.0 Update 2

Reporter or anyone else still seeing this issue with the latest Firefox 3 Nightly Build and the latest JRE Version ?
If not please close this bug as WORKSFORME. Thank you.
System Info:
I have noticed this problem recently in Beta [10.0], Aurora [11.0a2 (2012-01-10)] and Nightly [12.0a1 (2012-01-10)], but not the Stable [9.0.1]. I am running the plugin Java(TM) Platform SE 6 U30 on my Windows 7 x64, although my Firefox are all 32 bit.

It appears to occur for most Java applets such as:
http://javatester.org/version.html
http://chir.ag/stuff/sand/

I have noticed this occur in addition to the Search bar. I am still able to copy/cut/paste, but cannot see what text is being selected/highlighted. There is also no blinking cursor. Thanks!
Duplicate of this bug: 691326
Duplicate of this bug: 643085
http://wickedgoodgames.com/PacMan/PacMan.html
Still an issue on Firefox 10b5 on Win XP, Win 7 32/64.
See Also: → bug 868005
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.