Dragging multiple bookmark items moves only one

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: asolkar, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 11/06)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a5pre) Gecko/20070601 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a5pre) Gecko/20070601 Minefield/3.0a5pre

Trying to move multiple items (bookmarks or folders) between folders by drag-and-drop, I noticed that only one item is moved. Rest of the selection stays in the source folder

Reproducible: Always

Steps to Reproduce:
1. Open Firefox (Minefield version mentioned in the bug)
2. Open 'Bookmarks -> Organize Bookmarks...'
3. Select multiple items (folders or bookmarks)
4. Drag the selected items to a different folder
Actual Results:  
Out of all the selected items, only one item is moved. Rest stay put.

Expected Results:  
All selected items should be moved
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
moving to places
Component: Bookmarks → Places
QA Contact: bookmarks → places

Comment 2

11 years ago
WFM with Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a9pre) Gecko/2007101604 Minefield/3.0a9pre.

After moving 3 bookmarks several times, bug 398295 happens.

Reporter, is your bug reproducible with the latest trunk build? If not, please resolve it as INVALID, since it's places now. Thanks!
Whiteboard: CLOSEME 11/06
(Reporter)

Comment 3

11 years ago
Multiple bookmarks move fine in the nightly builds. Verified in Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a9pre) Gecko/2007101604 Minefield/3.0a9pre ID:2007101604.

Resolving bug INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.